TCCoA Forums banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
25 Posts
Discussion Starter #1
1995 Thunderbird with 4.6 V8 210K miles - Rough idle but only when in gear. Motor runs great in all other conditions. If I hold the break and up RPM just a little rought idle goes away. Troubleshooting suggestions?

Thanks,
Geoffrey
 

·
Registered
Joined
·
680 Posts
I hope you figure it out. . . that has been the definition of my car for 2 years
 

·
Registered
Joined
·
789 Posts
motor mounts
 

·
Registered
Joined
·
324 Posts
Transmission Range Sensor.............

Replace your Transmission Range Sensor, it's located on the drivers side of the tranny where the shifter cable attaches to a lever. It provides shifter postion info to the EEC allowing the ECC to adjust the Idle Air Control (IAC) for engine loads in Park, Drive 1 & 2, Over Drive and Neutral.

Chris..................
 

·
Newbie
Joined
·
5,650 Posts
Replace your Transmission Range Sensor, it's located on the drivers side of the tranny where the shifter cable attaches to a lever. It provides shifter postion info to the EEC allowing the ECC to adjust the Idle Air Control (IAC) for engine loads in Park, Drive 1 & 2, Over Drive and Neutral.

Chris..................
Highly unlikely that this is the problem. If the range sensor wasn't delivering a steady, accurate signal, there would be other problems like neutraling, strange shifting, etc.

How old are the plugs and wires? Are the gaps set correctly? Cleaned the MAF sensor? Changed fuel filter recently? Checked for vacuum leaks?
 

·
Premium Member
Joined
·
25 Posts
Discussion Starter #6
More Status

Plugs are new - Assume gap is correct as installed by trusted mechanic.
Wires are new
Fuel Filter is new.
Have not cleaned MAF
No vacuum leaks known.
 

·
Registered
Joined
·
1,252 Posts
MAFs do some funny things when they are dirty or bad. Just unplug it and see if it still does it.

There is more load on the engine in gear so it magnifies problems also EEC adjusts vs. neutral.
 
1 - 7 of 7 Posts
Top