TCCoA Forums banner

21 - 28 of 28 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #21
No check engine light. It came on once a cpl months ago for a p0402 egr excessive flow on recirculated exhaust gases. I installed a new EVR and cleared the code and it didnt come back on. Other then that no check engine light.
 

·
Registered
Joined
·
1,807 Posts
If there is anything remotely wrong with the EVAP solenoids, the CEL will illuminate, so no need to test them.

FYI, an EGR stuck open is a common cause of a rough idle. They are not supposed to be open at idle. Maybe the EGR controller or solenoid was bad all along, CEL be damned. The EGR doesn't just open on its own, so don't see how an EGR could cause excessive flow on its own.

The way to check an EGR is to apply a vacuum to It at idle. If the idle gets rough, then it's fine. In your case, if no change, then it was already open. You can actually hear the EGR diaphragm open and close when you apply a vacuum to it.

Al
 

·
Registered
Joined
·
412 Posts
If you pull the inlet tube off, hold the throttle blade open and look at it.

If it's black, it needs to have the blade and throat area cleaned.

Spray it with carb cleaner, then use a rag to remove all the black crap in the throat area, and get the backside of the blade; Especially the edges.

Be careful not to bend it, lol.

The black crap where it closes will cause off idle problems, in that transition region; I guess if it's bad enough, it could make it not idle.

Don't indiscriminately spray a bunch of carb cleaner down in there; you'll wash the black crap in the intake into the cylinders as a glob, and that's not good. :)

This being a 97, you could do a PI intake swap, and thoroughly clean the throttle body; eventually the EGR passages muck up. :D

It's a lot of hassle to clean out the intake/TB, so having a reason to unbolt it makes it easier.
I had an erratic idle situation, but it went away after I cleaned the TB. Thanks for the reminder.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #24
finally got time to play around some and cleaned the TB out as much as I could without unbolting anything. def noticed she idled a solid 50% better and had better acceleration.

soon when I can get the time I'm going to take the TB and elbow off and clean thoroughly. I also ordered a new egr valve because i found an original motorcraft egr with right PN and the vacuum line spout up top is offset instead of centered.
 

·
Super Moderator
Joined
·
10,298 Posts
Any time you clean something and it works better, reset the computer and let it relearn everything; otherwise it take a while to go back to normal.

Pulling fuse 15 under the hood and trying to start it clears the computer in a second.

Before you do plugs next time, do a seafoam treatment; search, there are directions.

It will make your plugs dirty if it's never been done, or at least it did to mine.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #26
Got this vibration issue resolved. Took off TB and intake plenum and got the old parts brush out and carb cleaner. Cleaned everything up and put her back together with new gaskets. Car idles beautiful now unless I cut the wheel. Thanks for all the advice you guys gave me.

Next up struts and tru duel exhaust. Got the parts just need to install :)
 

·
Super Moderator
Joined
·
10,298 Posts
Change the steering fluid, if you never have; mercon 5 is fine. Steering fluid is mercon iii.
 
21 - 28 of 28 Posts
Top