TCCoA Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
283 Posts
Discussion Starter #1 (Edited)
I have been just accepting it for a while but now I just need to know. First the car: 04 explorer block, ported exhaust manifolds, 02 MAF and airbox, Marauder TC, and most important...A Lonnie tune for 89 octane.

Now the issue: If I am going down the highway and let off the throttle the RPM's will drop 200-300 below "stable" point, jump up 200-300 above "stable" point, then end up at its "stable" point. I say all of that to say this...the needle on the tach bounces when I get off the throttle. This also happens if I am sitting in park and "pop" the throttle.

I have cleaned the MAF thoroughly, checked and replaced majority of the vacuum lines, SeaFoamed the the top half, and cleaned the contacts again at the chip. What else could it be? I discussed some of these issues with Lonnie and he assured me that this tune of so typical (which it is) that I has to be on my end and not his, I do believe that.

What else could it be. The car has been getting great instability in gas mileage, and the low end just doesn't seem to be there.

Please let me know.

WHAT ABOUT THIS??? http://forums.tccoa.com/showthread.php?t=66545


Thanks
JonFrank
 

·
Registered
Joined
·
583 Posts
Did this just happen out of the blue? No new changes?

It might be worth it to take a look and make sure the IAC valve is clean and working properly. Probably wouldn't hurt to make sure the TPS reads correctly at closed throttle, as well.
 

·
Registered
Joined
·
283 Posts
Discussion Starter #3
The changes happened suddenly. I stockpiled parts until I had a free weekend then, at once, I installed the TC, MAF, airbox, and Chip. It has happened since. There are too many variables there to start removing them to see what it is.

Also, you guys with the GT MAF, is your throttle response "crisp" or does it just idle back down like factory? I was expecting a little more response out of it.

And thanks Sophosis, I should have clarified that fact.
 

·
Registered
Joined
·
283 Posts
Discussion Starter #5
Are you talking about the link I posted? If so I am currently doing that now. I'll let you know, I feel that it is doubtful though.
 

·
Registered
Joined
·
283 Posts
Discussion Starter #6
No difference made with the one hour operation.
 

·
W&S Motorsports
Joined
·
161 Posts
A software routine does the dashpot function on the engine idle 'down'.
The present tune seems to let it undershoot followed by an overshoot, usualy treated as a 2nd order differential equation..remember the AP Math.
Sometimes set to slightly underdamped for 'crisp' respose. You can change the values if you have access to the tune.
 

·
Registered
Joined
·
283 Posts
Discussion Starter #8
No, I don't have access to the tune. I think I may have a difficult time pulling the chip, sending it to Lonnie, and surely we would have the issue of me expressing and him receiving the entirety of the symptoms the car is having to change the tune via mail.

Is this something I live with?

Thanks
 

·
Registered
Joined
·
283 Posts
Discussion Starter #9
Anything else I can do?
 

·
Registered
Joined
·
283 Posts
Discussion Starter #11
Thank you...
 
1 - 11 of 11 Posts
Top