TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1
Cleaned the MAF, still runs better when I unplug the MAF. SO I replaced the MAF with another known working one, same problem. NO CEL? Suggestions? It idles great, and runs well but when you rap the throttle it hesitates and boggs coming up when its plugged in. any thoughts. New plugs and wires(les than 100 miles0, before and after same condition. 4.6L THANKS.
 

·
Registered
Joined
·
320 Posts
My car was running like this but I had a light and code for the MAF. I never unplugged the MAF but I did clean it. Cleared the codes and the light came back on. I talked to a couple of mechanics and they told me to replace the TPS. So I did. My CE light stayed off and now the car runs a lot better. I guess if the TPS is sending a bad signal to the ECU and the MAF sends it signal. If the both signals aren't right. Then the ECU gets confused and doesn't run right. So you might check your TPS.
 

·
Registered
Joined
·
5,412 Posts
did you clean the maf yet?
 

·
Registered
Joined
·
5,412 Posts
tps iac?
 

·
Registered
Joined
·
29 Posts
Discussion Starter #6
OK, update, i forgot to reset computer by pulling fuse and trying to start, did that and now it wont go above 3500 rpms with the the maf plugged in any thoughts. Ill clean the iac and replace the tps switch, suggestions?
 

·
Registered
Joined
·
825 Posts
where did the other maf come from? if it was incorrect your gonna have problems. from what you describe I think your maf is bad. what did you use to clean it? how long did you let it dry? did you touch it? perhaps you need to get a magnified glass and look at it really close to see if the wires are broke on it. also have you checked for a intake leak?
 

·
Registered
Joined
·
29 Posts
Discussion Starter #9
The other MAF came from a 97 tbird, I cleaned the MAF with MAF cleaner, how long did it dry about 4 days. as far as spark plugs autolite dont remember the numbers. I have checked for intake leaks but will do so again, back to the basics. I examined the wires and they look clean and I can see no breaks in the wire. I will check again on both MAF. Thanks for the suggestions
 
1 - 9 of 9 Posts
Top