TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter #1
i was just driving to work the other day, was at a stop sign, started driving off.. and it didnt switch gears ( too 2nd ) till about 4grand... on the way home it only did it a few times.. and when i took the car just down my street to show my dad a few days ago.. it didnt do it for a good 2 or 3 stops ... any idea on what thsi could be? there's tranny fluid in it... could a flush / filter change fix this?
 

·
Registered
Joined
·
680 Posts
Check your fluid level. If it tends to happen more on hard stops or unlevel surfaces, I would be inclined to think that your tranny wasn't getting the fluid it wants.
 

·
Full Metal
Joined
·
4,744 Posts
sounds like the classic 1-2 accumulator problem. do a search, you'll find a few hundred threads on the subject and how to fix it. you are saying that it will not shift from first to second properly, right, not slipping as in acting like it is in neutral.
 

·
Registered
Joined
·
744 Posts
this should be in "driveline" forum

could also be a failed intermediate diode & drum (*i believe that's right part name, wait for darrin or the dog to jump in)


you have a 95, which are known for bad trans, but good news is we can make it better, so go figure it out, start by taking the pan off to inspect the fluid & see if you have any metal scards laying the pan
 

·
Registered
Joined
·
2,977 Posts
That could be the roller clutch failing. It could be the 1-2 accumulator too. Regardless, its not good and you need to get it looked at. DO NOT get suckered into a $1500 rebuild on that tranny no matter what.
Darrin
 
1 - 6 of 6 Posts
Top