TCCoA Forums banner

1 - 3 of 3 Posts

·
TCCoA Bachelor Club Pres.
Joined
·
1,267 Posts
Discussion Starter #1 (Edited)
Shake and shimmy 3.8 Probs

I own a 92 Coug LS with the 3.8, the only problem, well, one of, is that the engine has developed a horrible shake when I accelerate, depending on the RPM range the wheel will move up to 4 inches up and down with the vibration of the engine, other times the engine feels like it is about to die, and hardly moves unless you drop it to the floor, I have been to the local shop, they say the injectors are bad, and flushed them, that [email protected]$$ fixed it for a couple months, but it came back, I set the idle real high, and then had to store it for a few months, when I got her back the prob seemed fixed, except for because of the high idle, i was tearin through a tank of gas every three to four days, adn once I lowered it back, the problem seems to have gotten even worse. I am lookin for any help, comments, questions, etc. Thanks guys!:)
 

·
Registered
Joined
·
658 Posts
I would check your codes. Let us know what the codes say.

The things that I think would be a likely suspect would be a MAF or motor mounts.

danman
 

·
TCCoA Bachelor Club Pres.
Joined
·
1,267 Posts
Discussion Starter #3
Thanks, I thought after reading another article, that it might be the MAF too, and as for the mounts, I had a new 3.8 put in about 10,000 back, cause I toasted a head gasket spinnin the tires in the snow:D And I was showin a guy my engine and he said it looked like I was !missing! a motor mount. Thank you for the help, and any other suggestions would be appreciated.
 
1 - 3 of 3 Posts
Top