TCCoA Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
498 Posts
Discussion Starter · #1 ·
Engine threw a code yesterday... P1151
Ho2S21 - Engine running lean.
So its running lean. I did put a K&N cone on the car, would this be why it threw a code? Theoretically, according to my brain, if one side is running lean due to the cone the other side should be too. Or have I not acquired the proper 4.6 logic yet?
Or would tat be something else? Man, I've had a lot of car trouble lately :(
Anyway..would a chip fix it?
 

·
Slacks 12 months a year, TCCoAAC Member
Joined
·
2,530 Posts
Change the o2 sensor...

Change the o2 sensor and it will be fine.That one is located drivers side in front of the cat.Takes about 20 minutes to change,faster if the engine is cool.I have a scar on my left hand from it,lesson learned.
Ask whoever did the Diaoginistics which one it is exactly.But i am sure that is the one I had.
Good luck,
Chris
 

·
Registered
Joined
·
39 Posts
Could be your MAF

The oil K&N puts on their filters in my experience gets on the MAF sensor and collects dirt that will cause the MAF to have innaccurate readings. Try cleaning your MAF sensor (How-To in Tech Articles) then reset the computer by disconnecting the battery for a couple minutes. See if that helps. Good Luck
 

·
Registered
Joined
·
498 Posts
Discussion Starter · #4 ·
Cleaned the MAF this morning before I replaced the alternator just in case that was the problem. Turns out there was a 0 charge coming from it. So BAM. New alternator. Asked about o2 sensors, yeah they're $70 frickin dollars. Good lord...so as I was changing the alternator today I had the battery unhooked....no check engine so we'll see later if it comes on. I figure if I have to change it I'll go out at umm...3am or so :p
Thanks guys
 

·
Slacks 12 months a year, TCCoAAC Member
Joined
·
2,530 Posts
o2 sensors....

dont get them from auto zone.I did and ended up taking it back and going to Ford to get it.it was like 80 and some change.The one at AutoZone was totally wrong so I had to put the old one back in and go get the right one from Ford.
Good Luck,
Chris
 

·
Registered
Joined
·
498 Posts
Discussion Starter · #6 ·
Ford huh? How much did that run you? I'm not looking forward to seeing that code again *shudder* Sounds expensive.
 

·
Registered
Joined
·
1,431 Posts
Call (free) Max at....

Five Star Ford, tell him you're a TCCoA member and see
what our discounted price is - he or DanN will take
good car of you.

http://www.fivestarford.com/

Hope this helps,
 

·
Slacks 12 months a year, TCCoAAC Member
Joined
·
2,530 Posts
Max or Dan...

Both are very nice guys and very helpful.You will be amazed that there are still people like that on earth.
Chris
Oh,I paid like 80 and some change for my o2 sensor and they needed my vin number.
 
1 - 10 of 10 Posts
Top