TCCoA Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
294 Posts
Discussion Starter · #1 ·
Well I got Code p1407 a little while back, which as most of you know means "EGR, No flow detected"

Now I know what could be causing it, bad valve, DPFE sensor, or clogged tube, my problem is, I have no idea where these are or what they look like!

Can anyone give me a photo or diagram pointing out each of these parts?? :confused:


also: can you guys help me narrow down the cause? Since I got the code, the running state of my Engine has not changed at all, and I haven't really lost any noticeable MPG, which makes me guess that it is the Sensor that is bad, and there is in fact EGR flow, the computer just doesn't know it.
 

·
Registered
Joined
·
1,742 Posts

should be something like that. my mercury sable had a similar code. on my emissions tube there was a little nipple that has a hose. the hose went to the sensor that controlled the egr valve i guess. it was broken off so the sensor didnt know what was goin on. just inspect everyhting. an a freakin emissions tube for my sable was 100 bucks. it was like a foot long! i got one for free off a buddy's parts car. u should do the same if u need one.
 

·
Registered
Joined
·
147 Posts
The reason you dont know where they are is cause you cannot see them :D

Look at the center of the motor at the firewall. Then look down, there you will see the egr valve, its not the easiest to get to.

As to what the problem is, well you pretty much answered that in your post.

Hopefully someone who has had this problem can help you, maybe its the same problem and save you some time.
 

·
Registered
Joined
·
294 Posts
Discussion Starter · #4 ·
OTOWNBIRD said:
The reason you dont know where they are is cause you cannot see them :D

Look at the center of the motor at the firewall. Then look down, there you will see the egr valve, its not the easiest to get to.

As to what the problem is, well you pretty much answered that in your post.

Hopefully someone who has had this problem can help you, maybe its the same problem and save you some time.
yea I kinda knew what the problem was, but just wanted to confirm, the biggest part about this was I had NO idea where the parts of the system were located on the Engine! thanks for alerting me that it looks like a UFO t-bird lover :p
 

·
Administrator
Joined
·
14,394 Posts
Ask and Ye Shall Receive

The DPFE sensor is mounted right behind the intake plenum and is a major PITA to get to. I got the DPFE in April of 2003 for $52.13 tried to install it myself and gave up. I took it to the dealership and let them do the dirty work. I don't have a record of how much that was.

This diagram should be the same for a '94. If you need a larger copy of this diagram let me know.


 

·
Registered
Joined
·
294 Posts
Discussion Starter · #6 ·
yea, if you could get me a larger one that would be a great help!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top