TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2,514 Posts
Does the car feel like it has power if you rev it or does it feel like your at a loss for power?
 

·
Registered
Joined
·
3,391 Posts
I think you have a busted head man. You made sure that the timming was OK, all gaskets and everything and you still have problems??? Must be the head
 

·
Registered
Joined
·
2,514 Posts
yup thats what i thought it might be. There is something screwed up in the head and probably by the way it sounds there is something not sealed correctly and my guess its the head.
 

·
Registered
Joined
·
3,391 Posts
Mattscoug94 said:
Or the exhaust header (sorry just thought of this )


No, it's not the header. Even if the header was on the engine, it would make a loud sound, even higher than the one he has right now. Krazy, if I were you, I would take off the busted head and take it to a machine shop, they can tell you if it's busted or not. For me, that has to be the problem. Even if the timing waa off, you would still have SOME power.
 

·
Registered
Joined
·
154 Posts
Agreed, I'd have them clean and magnaflux the head to see if a crack has formed.

While your at it check the the coolant passages something might be blocking them.

Do you have good compression on that side on all cylinders, that would also give you an idea of weather the timing is off.

Just some thoughts
 

·
Registered
Joined
·
2,514 Posts
the reason i thought it could possibly be a leak in the header is because you can hear the pistons which in turn could be a crack somewere in the head and loss of compression. Have you done a compression test on each cylinder on that head?? I didnt mean there could be a bad header i meant there might be a leak in that general vasinity :) I hope you find out what it is man.
 
1 - 9 of 9 Posts
Top