TCCoA Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter · #1 ·
:confused: Not sure what is going on, but as I drive the speedo needle gets stuck. It hangs up around 35 mph, then jumps to 55 and sometimes jumps to 75 or so. Then as I slow down it hangs around 55 then drops to 20 and works normal to a stop. Ideas>?????
 

·
Registered
Joined
·
477 Posts
I beleive thats the beginng of the gears inside the speedo failing. I recall just before my speedo failed it would do that from time to time. To fix this get a junkyard speedo and replace the whole assembly. Also neverr rest the trip odometer while driving thats what strips the gears.

Will
 

·
Super Moderator
Joined
·
13,650 Posts
Odometer and trip meter gears operate independent of the speedometer. This sounds like some other issue. I agree that swapping the unit would be a good solution.

There are some good pictures of the speedo/odo guts HERE.
 

·
Registered
Joined
·
112 Posts
Discussion Starter · #4 ·
Yeah my odo and trip meter are working fine... (from what I can tell). I'm looking to sell the car in the next month or so, do you think the speedo issue could make or break the sale?
 

·
Super Moderator
Joined
·
13,650 Posts
Yes and no. Depends on the buyer.

It should be an easy fix if you've ever pulled your instrument cluster before. I would think a used cluster wouldn't be any more than $20 to $40 at a junk yard. Just follow the how-to that I posted the link to in post #3. The how-to is for the gears but pulling and replacing the whole speedo cluster would be basically the same.
 

·
Registered
Joined
·
123 Posts
hey i noticed that when i went to change my odo and trip gears that there was a ford id sticker inside the speedo ring and it kinda was doing the same thing when it was in my hand. would hang but then jump back to were it was supposed to be.. just my .02
 
1 - 8 of 8 Posts
Top