TCCoA Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
275 Posts
Discussion Starter #1
sometimes when i drive like normal ppl, nice and slow, my speedo wont show anything until i hit 35-40. I've heard of a lot of these going out, did it do this first? I normally drive fast and it moves around accourdingly, but at times it just dont do nuttin. Should i just get new gages??

Thanks
 

·
Registered
Joined
·
1,252 Posts
Probably the VSS in the transmission tail shaft going out.
 

·
Registered
Joined
·
275 Posts
Discussion Starter #3
sry but whats that stand for? VSS?
 

·
Registered
Joined
·
258 Posts
Vehicle Speed Sensor, I believe. It measures driveline rotation to spit out a reading based on known gearing ratios.
 

·
Registered
Joined
·
275 Posts
Discussion Starter #5
o ok thanks. ill look into that the next time it happens. i didn't mention earlier but no lights come on when the speedo isnt workin. wouldn't it thro a code?
 

·
Newbie
Joined
·
5,650 Posts
If you had a faulty VSS, you would have a code and the transmission would not shift normally. Most likely there is a connection problem to the cluster or the speedo itself is bad. The problem that you hear alot about in regards to the speedos is not that the needle stops working but that the odometer stops working, and this is due to the gears that drive the odometer breaking.
 

·
Registered
Joined
·
1,252 Posts
An intermittent VSS probably will not throw a code. If it happens fairly regularly it will throw a code. These things are cheap and easy to replace, so it you are running an original might as well put one in.
 

·
Registered
Joined
·
275 Posts
Discussion Starter #8
I'm a colloege student, so money is pretty tight right nowso I might wait till summer and see if its still working
 
1 - 8 of 8 Posts
Top