TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
235 Posts
Discussion Starter #1 (Edited)
95 Cougar 4.6

Ive cleaned the MAF and IACV. New fuel filter and pressure regulator. Plugs look good. Crank sensor has a new plug on it as the old one was broken.

Car is stalling out and wont start up for several tries. Car will fall on its face while driving but it only does it intermittently. Only codes are for the EGR and TCC but it has had those for a while. Ground wire near the battery went up in smoke as well and has been replaced.

I have searched hence what I have tried. Im out of ideas and cant afford to put it in the shop or throw parts at it that dont fix the problem.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #2
Got a gauge and the pressure was 32psi with the vacuum line on and 44psi with it off at idle. I didnt get a reading with the car off.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #3
I noticed one of my coils has a crack going right down the middle of it so I will be replacing the coil packs along with wires and plugs while Im doing those.

The problem seems to occur more when the car is heated up. I drove it yesterday morning and it drove fine but after returning home it would just turn over and not start after dying in the parking spot (at least it made it home and didnt die in the middle of the road this time).
 

·
Registered
Joined
·
81 Posts
It could be a fuel pump problem...or it could be a bad ignition module. I had the same problem last year. The car would cut off every once in awhile why'll driving, but it would start right back up. Until one day it died on me and wouldn't start back up. I checked everything, even pulled the timing cover to check the trigger wheel... In the end the ignition module was to blame. Its under the dash on the driver side. I could see module was melted in spots.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #5
Thanks for the headsup on the ignition module. I will take a peek at mine tomorrow.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #6
Car messed up again and I could smell plastic burning under the dash. I think Im gonna get the ignition module.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #7
So far I have changed plugs, wires, fuel filter, fuel regulator, ignition coils, ignition control module, and the crank sensor pigtail. Today when I drove it it would hesitate at more than 50% throttle and then died and wouldnt start. I have a crank sensor but havent replaced it yet. Anyone else have any ideas? Im stumped.
 

·
Registered
Joined
·
235 Posts
Discussion Starter #8
car finally threw a code for the crank sensor. waiting on a 10mm crow foot to pull the ac compressor to change it
 

·
Registered
Joined
·
235 Posts
Discussion Starter #9
Car ended up in the shop and their better code scanners discovered my MAF was bad. Car runs like a top with a new one. I also redid the crank sensor wiring one more time just because I didnt like how crappy I had done it before.
 
1 - 9 of 9 Posts
Top