TCCoA Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
112 Posts
Discussion Starter #1
Ok, there probably is an easy explanation and it has something to do with me being a dumb a**. Every time I purge the system, the motor will stall, then shortly after that, I get a check engine light with a p1443 code. I have the zex 75 dry system if that helps.
 

·
Registered
Joined
·
1,974 Posts
Did it ever work right?
If not, just a guess but maybe you have something wired wrong so that when you hit the purge button the Zex brain pulls vacuum thus having the EEC add more fuel.
Where in the main feed line do you have the purge solenoid connected?
 

·
Registered
Joined
·
112 Posts
Discussion Starter #3
From looking at it, it looks like the solenoid is connected about 20 inches before the brain. I don't know much about the system, it was installed before I bought the car, I'm just learning about it.
 

·
Whining Intakes Rock
Joined
·
3,645 Posts
You should follow the wiring and check for a short. In fact if it was me, I would yank the whole thing and rewire it again using fuses and relays.
 

·
Formerly Fdawg97LX
Joined
·
3,186 Posts
Al_Florida said:
You should follow the wiring and check for a short. In fact if it was me, I would yank the whole thing and rewire it again using fuses and relays.
:zwthstpd:
 

·
Registered
Joined
·
112 Posts
Discussion Starter #6
Yeah, I think changing the wiring isn't the problem. It is all fused and working properly. The only thing I can think of is, the brain has a vacum line running from it to a port on the upper mainifold and another line running to a diaphram (looks like a small EGR valve) behind the EGR valve.
 

·
Formerly Fdawg97LX
Joined
·
3,186 Posts
ResqBird said:
Yeah, I think changing the wiring isn't the problem. It is all fused and working properly. The only thing I can think of is, the brain has a vacum line running from it to a port on the upper mainifold and another line running to a diaphram (looks like a small EGR valve) behind the EGR valve.
the brain has nothing to do with the purge solenoid though. and that second vaccuum line is going to the fuel pressure regulator. thats how your car knows to add more fuel when you use the nitrous.

Frank
 

·
Whining Intakes Rock
Joined
·
3,645 Posts
Yeah, definately sounds like someone messed up the wiring.
 

·
Whining Intakes Rock
Joined
·
3,645 Posts

·
Registered
Joined
·
1,974 Posts
Fdawg03SVT said:
the brain has nothing to do with the purge solenoid though. and that second vaccuum line is going to the fuel pressure regulator. thats how your car knows to add more fuel when you use the nitrous.

Frank

The reason I thought it may have something to do with the brain is if for some reason when the purge button is hit, it somehow is sending power to it/activating it, and if it were to activate it could be flooding out the engine since the nitrous should be going into the purge solenoid instead of getting to the Zex brain.
Plus he's getting a code that could be related to something like that.





They are right thought. The smartest thing to do would be to just redo everything.
It would suck for something to either happen to your motor or something else because of someone elses install. Or at the very least pull everything relating to the purge (except maybe the solenoid) and redo that.
 

·
Whining Intakes Rock
Joined
·
3,645 Posts
Would it be possible for you to take some pictures of the setup under the hood? Specifically where the vacuum hoses are routed to from the controller.
 

·
Whining Intakes Rock
Joined
·
3,645 Posts
Aaron_T said:
The reason I thought it may have something to do with the brain is if for some reason when the purge button is hit, it somehow is sending power to it/activating it, and if it were to activate it could be flooding out the engine since the nitrous should be going into the purge solenoid instead of getting to the Zex brain.
Plus he's getting a code that could be related to something like that.
That's actually a good point. It would help to have a pic of the install. If the line is running to the evap valve and not the FPR.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #13
Thanks so far for all the imput... I'll get some photos up tonight. And yes Al_ Florida it is the same car as the one in the link. Good catch.
I am pretty fluent in wiring, so I'll start with the wiring to the switch (including the ground) and see what happens.
 

·
Registered
Joined
·
112 Posts
Discussion Starter #14
Well here is a basic photo of the hook ups... I'll try to get a more detailed one if needed.

 

·
Whining Intakes Rock
Joined
·
3,645 Posts
Yeah if you could. Hard to tell what's what there in the left most box.
 
1 - 15 of 15 Posts
Top