TCCoA Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have a 94 Cougar and I am having problems starting it in the mornings when it is cold. I have replaced the battery, spark plugs, and MAF to no avail. I got spark and fuel because when I turn the key I can hear my fuel pump run for 2 sec. like its supposed to. The reason I replaced my MAF is because I had codes showing it was bad. I thought that this would take care of my problem but helped for 1 morning and now it takes like 10 minutes to start. I just need help before i have to replace my starter from too much use. O it only does thisa when it is cold once i get it started and running it does fine throuhout the whole day.
 

·
Registered
Joined
·
249 Posts
Oh it only does this when it is cold once I get it started and running it does fine throughout the whole day.
Any Codes after the MAF one?

Take my suggestions with a grain of salt.

Check all under hood hoses, especially the ones involving the intake and EGR systems. If you try starting it and giving gas and it fires up fine look for a vacuum leak. A leaky EGR valve gave me this problem but fired up when given a bit of extra gas to offset the lean fuel/air ratio.

Haynes troubleshooting section for hard hot and cold starts has "Fault in fuel injection system" under cold start and not a problem for a hot one. I am assuming all you mentioned are perfect. If you did the above vacuum checks and all was fine make sure the injectors are clicking away properly, and check the injector resistances and make sure they are between 13.5 - 19 ohms.

Any other quirks you can think of that are odd can help with the troubleshooting.
 
1 - 2 of 2 Posts
Top