TCCoA Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
192 Posts
Discussion Starter #1
I was pulling into my garage the other day and i noticed that my steering made a very weird noise it was very tight and it almost sounded and felt like rubber on rubber when i turned to the right. I have noticed that the power steering has felt tighter and the steering wheel pulls to the right when i brake. I can clear a lane to the right when im braking. I have replaced upper ball joint on right and strut rod bushings on both sides. Any suggestions. I did flush the power steering once and put some valvoline synthetic and that didn't seem to help its still like chocolate. Thanks for any help
 

·
Registered
Joined
·
192 Posts
Discussion Starter #8
okay maybe not quite like chocolate but you get my point its very dark. does anyone know where i should start checking the car for problems. it seems like there is something loose when i turn the wheel left and the hard right. if its the rack how would i check that. Thanks for all of the chocolate jokes. LOL
 

·
Registered
Joined
·
2,894 Posts
chris said:
okay maybe not quite like chocolate but you get my point its very dark. does anyone know where i should start checking the car for problems. it seems like there is something loose when i turn the wheel left and the hard right. if its the rack how would i check that. Thanks for all of the chocolate jokes. LOL
Our racks are a POS design. Apparently, the brown is from burnt aluminum shavings from the racks. You really should flush the fluid again and go from there.

I don't see any info in your profile which describes year/model/engine/miles. Did you ever do the alignment after your front end work? Is your steering doing the classic whine?
Check out this thread .

After seeing your prior thread on this, I would also tend to lean toward the joint work that you've done and alignment if that isn't already looked at.

Would like to be able to help you more.
 

·
Registered
Joined
·
192 Posts
Discussion Starter #10
i have a 94 cougar with a 4.6 liter. I haven't had the car aligned after doing the strut rod bushing. I will probably do that now. I am going to flush the power steering again and see if that does anything. Everything under the car seems solid I don't know where to go after that
 

·
Moderator
Joined
·
8,239 Posts
flush it again and see what happens. It should not look like chocolate, but it should look like fresh vegtable oil when you are done.

Justin
 

·
Registered
Joined
·
192 Posts
Discussion Starter #12
okay i just flushed the power steering system with about a gallon of fluid. The entire time the fluid came out black. not until the last few flushes did the color clear up. i finished the flush with some valvoline synthetic and thats whats in there now. I noticed when i was under the car that when i push in on either side of the tire or pull out that the steering rods move in and out i don't know if this is normal just an observation and because I have been having all of these problems with the car pulling to the right during braking I thought that maybe there was something in the steering that could be the problem. I had never noticed this on my other car is that normal. Thanks for any more help
 

·
Registered
Joined
·
192 Posts
Discussion Starter #14
i would say that the wheels will move about a half of an inch or so. From what you say this is probably not a normal thing. I just noticed it today maybe I should bring it in a get it checked out. The tie rod ends seem fine but there is movement within the steering system.
 

·
Registered
Joined
·
81 Posts
Don't know bout the linkages, but...

I just flushed my power steering fluid this weekend. On a cold morning the noise is down 80%, and the steering effort is down like 20%. It's much smoother now. I used the Valvoline Syntec fluid. (It was ON SALE at Murray's this weekend.) The fluid was mostly clear on Saturday after one flush, but now it's a bit grey after 2 days. I figure one more flush next weekend will do it.
Try the flush, and good luck with the linkages/ball joints...I hope it's not expensive...
 

·
Registered
Joined
·
192 Posts
Discussion Starter #16
yeah i flushed a gallon through the system and its still dark. I think i must have a problem in the steering system. I don't have any leaks but the steering is tight. Does everyone elses steering wheel lock when you park the car because mine doesn't i odn't know if thats normal. The tie rods and ends look good but the wheel movement is what scares me. The haynes manual says to lock the steering column before removing the gear and if i can't even lock it thats going to make the whole thing tougher. Thanks
 

·
Registered
Joined
·
137 Posts
flushing without making a mess?

so when you pull that p/s hose off, the fluid isnt going to splash all over my engine from the resevoir is it?, or will it only come out of the hose
 
1 - 17 of 17 Posts
Top