TCCoA Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,273 Posts
Discussion Starter #1
ok well i have have posted allot on here about this..... but im starting to get REALLY REALLY tired of driving my car around with 1/4 the power its supposed to have, and getting 13 MPG... well it seems to run fine and 1/8th throttle the but who drives around at 1/8 throttlle anyway. as soon as you push to 1/4 or 1/2 throttle the RPM will go to 2000 and almost stops moving, wile the Speed keeps increasing VERY VERY VERY slow. you can feel the car wanting to go but its like something is holding it back. i know the first thing you going to say is pluged CATS but it runs beutifully every now and then and cats dont plug and unplug.... i have replaced the MAF, TPS, plugs and wires, fuel filter( on right way), changed fluid and filter in trans. my trans seems to shift ok too and the OD works fine. if anybody has had similar problems or knows whats wrong im ready to hear about anything right now....
 

·
Registered
Joined
·
518 Posts
Actually I had a car several years ago that the cats would plug and unplug. Sometimes I could feel the exhaust flowing out smoothly at the muffler tips and other times (when the car had no power) I would feel nothing. I assumed it was chunks of the element breaking loose and plugging the exhaust and then eventually working it's way out. After a couple months though all of the loose crap must have worked it's way out cause I never had another problem after that.
 

·
Registered
Joined
·
1,273 Posts
Discussion Starter #4
its smooth acceleration no surging or anything. just really slow and laggy
 

·
Registered
Joined
·
184 Posts
Yes cats do plug and unplug!

My daughter's 1996 T-bird's cats started to melt internally, and the cat "brick" would just rattle around inside the shell. If yours are damaged, you could have them not plugged once in a while, enough to let you know your car can still run.
 

·
Registered
Joined
·
803 Posts
I would agree with fuel pressure checks first. Rev the engine up and watch to see if it dips also. Fuel filter is a cheap and easy part to replace.

So the car still accelerates even though the rpm stays the same, but rpm will not go above 2000 even during WOT?
I would think a car doing this would be throwing at least one code.

Since you don't mention it then the EEC thinks things are fine.

You don't mention if the engine will rev without load. Does it act normal in neutral? Can you floor it and have it rev up beyond 2k like a normal car?

If you really think about it, it sounds to me like it thinks it is at the rev limiter. Does it stumble or bounce like that?

At any rate, I would either pay for a decent diagnosis or start replacing things from the cheapst up. My money would be on the EEC if it ends up the exhaust breaths ok and fuel pressure is good.
Injectors are driven by the EEC. You might check to see how much voltage is being driven to the injectors.
 

·
Registered
Joined
·
518 Posts
Easy way to check ur exhaust, just feel how much is coming out of the tailpipe. If it's plugged you will barely feel any exhaust coming from them. If you're not sure about how it should feel check another vehicle. Should be pretty noticable, at least mine was when it clogged.
 
1 - 10 of 10 Posts
Top