TCCoA Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
1,731 Posts
Discussion Starter #1
Im having an issue with my A/C sometimes I turn it on and its ice cold and stays that way, sometimes it is warm from the start, and sometimes its cold and get warm. Im thinking compressor but it seems to come one and go off as it should. Any ideas? and if ts the compressor how much am I looking at? I NEED a/c lol.
 

·
Registered
Joined
·
2,876 Posts
You need A.c. in New York? You need to come down here. Any ways. It sounds like it is the compressor. You need to check how much freon is in the system. May have a leak. Just may need a refill. Then you will only have to pay like $20 at the most.
 

·
Registered
Joined
·
1,731 Posts
Discussion Starter #3
lol I know its really not that bad but I get hot sitting still lol. Its not bad here yet but its gotten warm quick, and with the humidity its horrible. I can take heat as long as the humidity is low lol. I have the kit with the pressure gauge, I guess Ill give it a shot but I figured Id ask since sometimes its cold and not others.
 

·
Super Moderator
Joined
·
7,662 Posts
Before you go putting a compressor in it, do a little more research. First, make sure the system is fully charged. If the charge is good, it could be as simple as a blockage somewhere in the system, which would be a much cheaper fix than the compressor.
 

·
Registered
Joined
·
2,876 Posts
I'm really thinking it is a low freon problem. The clutch isn't engaging when it is LP. Sometimes when it is hot the pressure goes up and it will work. Just my .02 worth. May not be it.
 

·
Registered
Joined
·
1,731 Posts
Discussion Starter #6
Thanks a lot I will be doing the check on the pressure today as soon as I get home assuming I can find the gauge lol.
 

·
Registered
Joined
·
1,731 Posts
Discussion Starter #8
well I went yesterday and hooked up the gauge and it shot up way past the danger zone. I have never filled the a/c before nore has is been done in the 2 years I had the car so I think something is screwy and im not sure what. I emptied it with a screw driver and tried to refill it but it wouldnt take any r134a from the can. YES i did have it hooked to the low pressure port lol. Any ideas where all the pressure came from? It worked after my accident (got it back on the road last September) and didnt use the a/c much but I know it DID work but could something of happened since then?
 

·
Super Moderator
Joined
·
7,662 Posts
You have a blockage somewhere in the system. The most common places to get blocked up are the orifice tube and the accumulator, though it could be other places too. If there was still refrigerant in the system, you would be able to go along the lines and see where it suddenly drops temperature, and that would be where the blockage is. Unfortunately since you discharged the system, you can't do that now, so I would reccomend replacing the orifice tube and accumulator for starters, since they are both pretty cheap and easy to replace, and see if it takes a charge and works properly after that.
 

·
Newbie
Joined
·
5,650 Posts
The accumulator for a 3.8L isn't exactly cheap coming in at around $100.

If you are going to replace the orifice tube, I'd recommend getting the whole liquid line with the orifice tube. It will cost about the same as getting the orifice tube itself plus the kit to install it in the line, and you won't have to worry about cutting the line you have now.
 

·
Registered
Joined
·
1,731 Posts
Discussion Starter #11
Ok Ill look into it. Im wondering if my accident had anything to do with it because after the accident I found some kind of oil all over that side of the motor/hoses and I didnt brake anything that I saw that would cause this. Mike I know your out in Jersey and not to far from my friends house , hes exit 98 off the GS, how much would you charge to take a look at it, I dont want to start throwing money at it if im not sure what im looking for, you know what i mean? Let me know if you can/ would take a look at it for me. Thanks, Jon.
 

·
Super Moderator
Joined
·
7,662 Posts
I would check it out for you, but I have WAY too much stuff going on right now. Maybe in a few weeks I could do it on a sunday, but right now I have to swap the motor in my firebird, rebuild the motor for my 89 XR7, swap a motor in a guy's 41 chevy, repaint a mercedes for another guy, and I haven't even gotten to the stuff I have to do around the house yet.
 
1 - 13 of 13 Posts
Top