TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
566 Posts
Discussion Starter #1
I was changing the fluid and replaceing the 1-2 accumulator with the updated version. Just before I reinstalled the pan an unexpected storm came up with strong winds and rain.

While I was reinstalling the pan water was running down from above me, past the pan as I was installing it. There might be a small amount of water that made it inside.

Should I take the time to remove the pan again and wipe out any water before adding the fluid? Should I just let it sit for awhile before adding the fluid and hope it will evaporate ?

Wishing I had a garage.


Thanks,

Joe
 

·
Registered
Joined
·
298 Posts
You need to get that water out of there before you run it.


Water will kill the clutches quick like!

So drop that pan, you know you love Mercon V showers as much as me :D
 

·
Registered
Joined
·
566 Posts
Discussion Starter #3
How much water do you think would cause a probem?
There is probably only a few drops inside.

Joe
 

·
Registered
Joined
·
298 Posts
JNT said:
How much water do you think would cause a probem?
There is probably only a few drops inside.

Joe
If it was my car, and there was just the possibility of water, I would dump the pan.
 

·
Registered
Joined
·
566 Posts
Discussion Starter #5
Thanks for the advice.

Not the solution I was hopeing for, but better safe than sorry.

Joe
 

·
Registered
Joined
·
566 Posts
Discussion Starter #6
Well I dropped the pan and wiped it out, didn't see any water. Nothing like having to do things twice:redmad: , but I feel better knowing it was clean.

Joe
 
1 - 6 of 6 Posts
Top