TCCoA Forums banner

1 - 10 of 10 Posts

·
$.25 poster
Joined
·
1,900 Posts
Discussion Starter #1
I've had this car for about 5 years and I never noticed this until recently...When cruising on the highway at speeds 65+ the car does not seem to want to do it. The motor feels like its straining itself to run at these speeds, but the RPMs seem to be in normal range. The motor feels like it is trying much harder then it needs to be. It is almost a strain on my foot to keep the gas pedal down, and as soon as I left off the car slows dramatically.

Kinda has been making highway driving a displeasure. I don't have a clue why its doing this, any ideas?
 

·
Super Moderator
Joined
·
12,021 Posts
IDK, Probably needs a tune up. Clean the MAF, Clean or change the air filter, Plugs, wires, Seafoam the engine and put a can in the gas tank, change the trans fluid, etc. the kind of stuff you may not do all the time.

You don't have a lot of modifications listed in your sig. My guess is it's the basic stuff. Try any or all of the things listed above and see if it makes a difference.
 

·
$.25 poster
Joined
·
1,900 Posts
Discussion Starter #3
yeah i will, seafoam is great and I have used it in my jeep with great results but i am reluctant to use it in the T-bird. Between my oil and coolant leaks, I am afraid the seafoam will clean out the motor so well it will make my problems even worse lol
 

·
Registered
Joined
·
658 Posts
well just my 2 cents but have you made sure your brakes are not catching or something isnt rubbing causing you to loose speed fast? again just my 2 cents.
 

·
$.25 poster
Joined
·
1,900 Posts
Discussion Starter #6
I'll have to check the temp next time I drive it. I know that one or two of my cats are on the way out as they are rattling. Other then that I do not know, the filter is a k&n and it is clean.

oh yeah, and I have had a CEL on for a while, code came up as something to do with the evap purge solenoid.
 

·
Registered
Joined
·
431 Posts
Rattling cats is what I had before the media in there shifted onto its side or something and plugged that side entirely. Could feel it getting slower over ~100 miles or so before it was completely stopped up. Foot on the floor in neutral it revved up to 3500 and stopped. Sounded very strange too.
 
1 - 10 of 10 Posts
Top