TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
524 Posts
Discussion Starter #1
1995 T-Bird 4.6L

151800 Miles.

Car is surging, backfiring out of intake, has a shaky idle (whole car shakes). Does it cold and hot. Give it more throttle, hesitates harder, backfires more. WOT clears up and runs strong. Let off gas, give about 1/2 throttle, begins to backfire more. Ran 89oct in it tonite and did not help issue at all.

I have a cone filter set up where filter is ran in between support fixture for original air box.

So far I have..
-Cleaned fuel injectors
-Replaced plugs and wires twice within 30k miles
-Replaced fuel filter around 20k ago
-Top Engine Clean(BG's induction clean)
-Checked Coil Packs
-Cleaned MAF
-Checked IAC
-Checked TPS

I got it scanned and I have a P1151 which means its dumping fuel like mad. My gas milage went down to 8mpg!!!! I don't think it is the O2 sensor because this happened after I did a fuel rail injector clean (ran through schrader valve).

I am stumped and I cannot figure this out at all I need some help. This has been a ongoing problem since August and its getting worse.

Thanks.
 

·
Registered
Joined
·
3,748 Posts
bump for you. can anyone help this guy?
 

·
Banned
Joined
·
377 Posts
-bad fuel pump (a dying fuel pump can put out to much fuel or not enough)
-bad fuel pressure regulator
-one or more of your injectors is leaking or shorting (been there done that)
 

·
Faster than Porkchop
Joined
·
2,037 Posts
Check your sparkplug wires , they might be arching .
 

·
Premium Member
Joined
·
441 Posts
94 and 95 ECUs are known to develop a problem that hangs injectors open, that could account for the rich code. Are you seeing black smoke out the exhaust?

Bob
 

·
Registered
Joined
·
5,408 Posts
sounds like a hanging injector to me as well
 

·
Registered
Joined
·
524 Posts
Discussion Starter #7
It pulls hard at WOT, today I was driving it and it was fine.

This is the problem its intermittent.

When it misfires, I do notice a tad of black smoke if its at idle from a take off. So rich for sure.

I'm going to pull plug wires and go from there. When I pinpoint it i'll do a comp. check also.

The only thing is it feels like its more than one cylinder, but I could be wrong. Could a completely dead cylinder on a V8 cause a severe shake like that?

Also the popping from the intake. ITs only under load when it does it. Could this mean the amount of fuel being dumped and sitting in the cylinder for the next stroke too much causing the intake stroke a pre-detonation?


Also the car misfires since I have done a fuel injection clean (through fuel rail). Soon as the cleaning agent was done I started it up and the first time I drove it it acted up.
 

·
Super Moderator
Joined
·
11,961 Posts
i say that fuel injection cleaning messed up your fuel pressure regulator, or it was bad to begin with, or maybe it isnt getting the right amount of vacuum

what is your fuel pressure sitting at with the car on and with the vacuum hose disconnected?
 
1 - 9 of 9 Posts
Top