TCCoA Forums banner

1 - 6 of 6 Posts

·
motor city poster
Joined
·
2,029 Posts
Discussion Starter #1
Hey all.

My suspension currently has a sqeak to it and before i tear it apart i was looking for some ideas...

it only does it while driving straight down the road, no vibrations etc. just noises.

all recently replaced...

ball joints upper and lower both sides,
shocks and springs (shock mounts also) (re used old spring insulators)
sway bar end links

im leaning towards the spring insulators because they were kinda nasty when i put my lowering springs on but the new shocks didnt come with any so i re-used them.

any ideas, also it doesnt make the noise while turning so i think that kinda rules out the ball joints
 

·
Registered
Joined
·
118 Posts
Does the noise happen when you're going over bumps? When I lowered my car, I reused the old insulators and got a squeak when the car would come down on the suspension. I learned after the job was done that I was supposed to have greased the insulators before I reinstalled them to prevent this. If you did the same thing, I just took a spray can of lithium grease and sprayed it in there as best I could. It didn't cure it but it made it better. I'm thinking that if I spray it again it might take care of it. Hope that helps.
 

·
motor city poster
Joined
·
2,029 Posts
Discussion Starter #3
thats what i figured...mine looked pretty sad when i swapped them over...so i think im going to try to find replacements... and its doing exactly like you described when coming down over bumps.
 

·
Registered
Joined
·
64 Posts
My suspension is quite usually, but during cold weather the front suspension eminates this loud crunching noise on bumbs... goes away onces the sun comes out and it warms up outside.
 

·
motor city poster
Joined
·
2,029 Posts
Discussion Starter #6
FIGURED IT OUT!

problem seems to be located in the "NEW" upper shock mount, the mount is almost actually coming apart, the middle kinda moves inisde the outer part,

so i orderd a new shock mount and it should fix the problem

you can actually see it move, and the passengerside doesnt do that
 
1 - 6 of 6 Posts
Top