TCCoA Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Question about sway bar end links and heavy sway bar.
Did the full front end repair tokico springs & shocks and Addco 1 1/4 sway bar.
I put on new sway bar end links, UCA, LCA, strut mounts, everything.
I have cut and ground the shock mount bracket to clear the Addco sway bar. PITA
I have a rattle in the right front suspension that I think is a sway bar end link, (OEM straight design)
Is it possible to burn out an end link with the heavy duty sway bar?
I thought they would last a long time.
I do have the shorter angled links to install.
I'm hoping that the bar will be in another position to clear the shock mount bracket better.
 

·
Registered
Joined
·
170 Posts
Question about sway bar end links and heavy sway bar.
Did the full front end repair tokico springs & shocks and Addco 1 1/4 sway bar.
I put on new sway bar end links, UCA, LCA, strut mounts, everything.
I have cut and ground the shock mount bracket to clear the Addco sway bar. PITA
I have a rattle in the right front suspension that I think is a sway bar end link, (OEM straight design)
Is it possible to burn out an end link with the heavy duty sway bar?
I thought they would last a long time.
I do have the shorter angled links to install.
I'm hoping that the bar will be in another position to clear the shock mount bracket better.
Look at the hole on the bar where the link mounts. Mine was too big and i had to weld a washer on the bar so the link stud did not bounce around in it. That could be your problem. Also look at the frame rails of the car and make sure you are not making contact with the bar there also. If so pry the lip of the frame rails to give you clearence. I was hoping they would have fixed this by now.
 
1 - 2 of 2 Posts
Top