TCCoA Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
i got a 94 3.8 and i have put dual exhaust on it with no cats or anything just pipes and mufflers and now my car kind of sputtters after i let of the gas when going down the road and when its real cold it shifts kind of late and i really dont think its the trans. feels like somthing it up with my gas . i put new oil pump on it and oil gauge thats by the pump and some how i still get low oil pressure WTF lol. someone said that could be do to not enough back pressure from my exhaust.. all of this.
i got 2" pipes going back into 40 flows. also put 2 new 02 sensors on the car and i also put a bigger MAF on it too, maybe somthing is up with the maf
Can anyone help me with this sputter problem i have?
 

·
Premium Member
Joined
·
2,976 Posts
why did you put on a bigger maf? put your old one back on. I bet that will fix your problem. You have NO need for a bigger maf. hell, I know of modified 4.6's that are still using the stock maf.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4
i thought it would add more HP hehe... well i got a cam reground for the motor and heads done up. thought i would need more air going through too..,. soo i put bigger MAF
 

·
Premium Member
Joined
·
2,976 Posts
In order to use a bigger MAF, you need a chip to let the computer know you have a bigger maf.
 

·
Registered
Joined
·
689 Posts
Litning said:
In order to use a bigger MAF, you need a chip to let the computer know you have a bigger chip.
dont you mean bigger maf john :confused:
 

·
Registered
Joined
·
31 Posts
Discussion Starter #7
welll im going to change out the MAF today to see if it help :) .. thanks for the help bros
 

·
Registered
Joined
·
31 Posts
Discussion Starter #8
fck i dont have my old one, guess i will have to go to a junk yard to get one. but b4 i do.. would the MAF be causing this super bad gas milage, sputtering after letting off throttle, low oil pressure(after putting in new oil pump and new oil senser), and late shifting when the motor is real cold?
 

·
Registered
Joined
·
31 Posts
Discussion Starter #10
maybe the oil pressure is just the gauge in my car. sometimes its normal and somtimes it goes a lil low.
 

·
Moderator, Iowa Chapter Director, Uber Luber, TCCo
Joined
·
8,978 Posts
the oil pressure gauge is a dummy gauge. It's either reading pressure or it's not. So if it shows "a little low" then its fine.
-Thomas
 

·
Registered
Joined
·
31 Posts
Discussion Starter #12
ya it never goes all the way to low .. must be the gauge. thx for the help guys
i gotta find a MAF somehwere none of the junk yards around here got one :(
 

·
Premium Member
Joined
·
2,976 Posts
cougarfan said:
dont you mean bigger maf john :confused:
yup, thanks joe... was on the way out the door to my sister's college when i wrote that
 

·
Registered
Joined
·
31 Posts
Discussion Starter #14
OMG it was the MAF i found my old one in the shed and put it on and it runs just fine now hehe. thanks for the help guys !! now i can sell this piece of sht haha
 
1 - 15 of 15 Posts
Top