TCCoA Forums banner

1 - 20 of 21 Posts

·
02 Explorer Pioneer
Joined
·
2,880 Posts
Discussion Starter #1
Anyone who has had to replace their tcc solonoid what were the symptoms? I think this is my issue. After the car is warmed up (15 minutes driving) when pulling up to a light the engine will drag down below 500 RPM and stall unless I give it a little gas or pop it in neutral. I am fairly certain the tcc is partially locked when this happens but I was wondering if the tcc solonoid can partially fail like this or is it all or nothing? The only other thing that could be happening that I can think of is that the seals around the plunger have gone bad and it's not fully depressing the shaft. Is there a definitve way to test either scenario?
 

·
Moderator
Joined
·
8,239 Posts
is this the original trans Tim?

My 95 would stall at redlights after long highway runs, it turned out to be the TCC Solinoid.

You had to give it a little gas to keep it from stalling.

JH
 

·
02 Explorer Pioneer
Joined
·
2,880 Posts
Discussion Starter #3
Yep origional trans 235K
I guess I go pick up a solonoid tomorrow and prepare for a mercon shampoo :D

Thanks for the response...sounds like the same thing
 

·
Registered
Joined
·
54 Posts
Actually I had the same symptoms. I thought it was the TCC solenoid too, but it turned out to be the Idle Air Control. One way to differentiate is put the car in Park and turn on your AC. If you idle starts to oscillate up and down, it's probably your IAC. I would check the IAC first and clean it out (I used Oxygen sensor safe Gum-out). I found a lot of carbon deposits in there. After cleaning and reinstalling, no more stalling and no more idle fluctuations while the AC is on. Hopefully this is helpful for you. Good luck.

-Leo
 

·
02 Explorer Pioneer
Joined
·
2,880 Posts
Discussion Starter #5
Just a follow up the new tcc solonoid did the trick
 

·
02 Explorer Pioneer
Joined
·
2,880 Posts
Discussion Starter #7
Hahahahahaha

Actually it doesn't look like the trans was the issue....I wouldn't dare try to use it anymore but it looks like the coverter balooned and bits of it broke apart inside and the housing cracked. There is a nice stream of Merc V coming out the bellhousing drain hole :eek:
 

·
Registered
Joined
·
1,040 Posts
Better tell Andrea to put the bucket under her when she arrives home otherwise you will have the Mercon pool in the driveway after all!;)
 

·
Registered
Joined
·
364 Posts
I have the same problem... still I replaced the TCC solenoid... no change.. I noticed it from the way home from Doing the J-Mod a while ago my O/D light started flashing... If I put it in 2nd and a stop and hit the gas the car will usually stall

So it looks like the TCC "solenoid" is electrically stuck on... not mechanically right..?

Anyone have this problem and the solenoid didn't fix it?

I don't really wanan mess up the car to much.. and I wanna put a 2500 stall TQ in it and I would like to have this problem fixed before I do that.. :(

any help would be great... :)
 

·
Registered
Joined
·
364 Posts
ttt :(
 

·
Registered
Joined
·
1,072 Posts
where are you guys getting these TCC Solenoids?

My dealer here in town wants 120 bucks!!


napa can get me one... but they say its will work for 94 THROUGH 98...


which I know to be wrong, because the 94-95's were different than the others. (lower ohm's or something)


thanks guys

MG
 

·
Registered
Joined
·
364 Posts
120? there like 20 bucks or something...
 

·
Registered
Joined
·
926 Posts
I had this happen before too and it was the Torq conv :( as well
 

·
Registered
Joined
·
364 Posts
why would be be the TQ? how...? I'm going to put a new one in anyways.. I wanted to fix the problem before I did... btut if it was a TQ problem then would be cool. but I doubt it is/was/could be
 

·
MaleWhore
Joined
·
2,640 Posts
sorry to maybe get this out of the topic, but what are some sypmtoms of a bad Throttle position sensor?
 

·
Registered
Joined
·
3,178 Posts
I got a TCC shipped to my door from Dan Newman for ~$24. For that kind of cash I'd buy it from him and then see where it goes, especially if it appears the TCC has failed.
 

·
Registered
Joined
·
926 Posts
smokymance said:
sorry to maybe get this out of the topic, but what are some sypmtoms of a bad Throttle position sensor?
Usually your car will idle up and down trying to find a idle becuase the TPS is stripped inside and its not staying @ .99 volts @ idle. You could test it with a Multimeter use the mV setting. Usually thats what they do when they go bad. Good Luck :)
 

·
Registered
Joined
·
1,072 Posts
Lazania said:


Usually your car will idle up and down trying to find a idle becuase the TPS is stripped inside and its not staying @ .99 volts @ idle. You could test it with a Multimeter use the mV setting. Usually thats what they do when they go bad. Good Luck :)

thats exactly what mine did

mg:)
 

·
Registered
Joined
·
286 Posts
Put the car in manual 2nd. If the TCC solenoid is stuck, or if its driver in the PCM is shorted or the wiring is shorted to ground, the tranny will try to stall the engine.

A little electrical sleuthing will save a lot of time and $.
 

·
Registered
Joined
·
1,072 Posts
interesting... mine does this on occsaion...


just another problem this 94 peice of $#^% has ...

and more reason to get a new TCC for the new tranny rather than swapping the old into the new.


MG
 
1 - 20 of 21 Posts
Top