TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter #1
Yet the latest in my wonderful series of problems. I tried "burping" the cooling system like was suggest and still no luck. I have added more water to that thing than a fish drinks in a year. (about 5 jugs of 50/50 i think) I know she is not leaking and the headgaskets are good (just replaced them and the oil is not milky). When ever I try and drive it she slowly warms up to about the "n" in the norm then if i continue to drive her the temp jumps up to near the red. I have been trying to get the air out by driving it around and getting it warm, shutting it off, taking the vent plug out to releave the pressure and topping of the radiator. The upper hose gets very hot and feels like it has just air in it and no coolant. Could it be a stuck thermostat, or should i just keep doing what I am doing cause there is an air bubble somewhere?
 

·
Registered
Joined
·
892 Posts
Yet the latest in my wonderful series of problems. I tried "burping" the cooling system like was suggest and still no luck. I have added more water to that thing than a fish drinks in a year. (about 5 jugs of 50/50 i think) I know she is not leaking and the headgaskets are good (just replaced them and the oil is not milky). When ever I try and drive it she slowly warms up to about the "n" in the norm then if i continue to drive her the temp jumps up to near the red. I have been trying to get the air out by driving it around and getting it warm, shutting it off, taking the vent plug out to releave the pressure and topping of the radiator. The upper hose gets very hot and feels like it has just air in it and no coolant. Could it be a stuck thermostat, or should i just keep doing what I am doing cause there is an air bubble somewhere?
Not enough information. I will tell you I have bought and installed a brand new thermostat and had it bad. Drove me nuts!!!!!!!!!!!! Sounds like a thermostat or a collapsing lower hose.

Brad
 

·
It is nice
Joined
·
885 Posts
if the hose feels like air it seems likely its the thermostat not opening fully. I would take out the thermostat boil it in a pot of water to see if its working a thermometer would be ideal to see when it opens but at least you can see if its opening at all and isn't getting stuck from old crud on it. might as well buy a new one when you remove it and check both before installing. (spring towards engine) so 3.8 would be spring towards back of car. Has the car ever shut down while driving from overheating?
 

·
Registered
Joined
·
47 Posts
Discussion Starter #4
not yet, i try and avoid letting it get that hot. What more info do you need? The lower hose does not appear to be collapsing.
 

·
Registered
Joined
·
892 Posts
not yet, i try and avoid letting it get that hot. What more info do you need? The lower hose does not appear to be collapsing.

Still question the thermostat 1st, even if new. I would follow the suggestions, could be a cheap fix.

Brad
 

·
Registered
Joined
·
1,122 Posts
A plugged radiator or failing water pump could also be a problem. Make sure you have the recommended t-stat and that all your hoses are tight.
 
1 - 6 of 6 Posts
Top