TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6,111 Posts
Discussion Starter #1
Okay, so last october, I replaced my entire front end on my car...everything, well, shocks and springs where not replaced, but the shocks where almost new, and the springs are fine.

I had an alignment and balance done as soon as we got the car back together...everything was perfect on it for about two weeks, then I started getting knocking, popping sounds in the front end when turning the wheel, going over speed bumps (slowly) etc. and I Have been easy on it, no beating on anything.

I took it in recently for new tires...the allignment was REAL bad and the drivers side lower control arm was loose. They put new tires on, alligned it, and tightened down the loose parts. once again, everything was fine. for a week.

A week later, all the same problems came back...so I took it back. They looked at it, and said strut rod bolts where loose...they tightened...all was good...for a week.

Now the whole front end is loose again, making noise, feels terrible.

Here's another common problem I've had through all of this...when I get out of the car after driving and dealing with noise, creaks, squeeks, popping and a loose feeling front end, the suspension on the drivers side will be creaking for a while AFTER I get out of the car...it really feels like the whole thing is about to fall apart.

NO joke, the suspension felt better with 85,000 mile 15 year old warn out parts :(

not to mention dude at supercoupe performance won't tell me who manufactures these parts so I don't know who to turn to if it turns into a warrentee issue....

I don't know what to do but I am EXTREMELY frustrated....
 

·
The Band, not the Disease!
Joined
·
3,090 Posts
The parts are good, but your just having issues keeping the bolts tight? Are they torqued to proper spec? Try locktite also
 

·
Registered
Joined
·
6,111 Posts
Discussion Starter #4
the only bolts/nuts that where replaced where whatever parts came with new ones...other than that....re-use....interesting...
 

·
Registered
Joined
·
7,758 Posts
Technically you are supposed to replace all the nuts when you take them off, so if you haven't they may have lost their locking ability.
+1 I believe those strut rod nuts are like crimp nuts or lock nuts. They are not designed for repeated use and eventually lose their locking ability.
 

·
Registered
Joined
·
1,170 Posts
+1 I believe those strut rod nuts are like crimp nuts or lock nuts. They are not designed for repeated use and eventually lose their locking ability.
Use locktite red for large threads on the strut rod. Chances are if you replaced everything you will not have to remove it for another decade. Also, make sure it is tightened with a torqure wrench to 150 ft/lbs with the bird on the ground or on ramps . Remember you are tightening against a rubber sandwich. It is difficult to judge by hand.



P.S. DO NOT USE LOCKWASHERS ON ANYTHING. Here is proof if you are bored: http://www.boltscience.com/pages/helicalspringwashers.htm
 

·
Registered
Joined
·
34 Posts
yea just replaced my front end, biggest pain was finding proper replacement nuts (hub nuts were 13.50 a piece!). Pretty much every nut has a crimp head or nylon insert. And pretty much every nut should be replaced! (according to ford manual)
 
1 - 7 of 7 Posts
Top