TCCoA Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2,656 Posts
Discussion Starter · #1 ·
ok, i've put up with this for about three weeks, but after getting teh headgaskets replaced, i noticed that the throttle pedal (whether teh car is on or not) is a little weak-ish.. there isnt any resistance when i push it down, and it is making keeping a constant speed hard... i got under the hood and manually revved it, and it is just as spongy at teh throttle body... i think the spring isnt wound up completely or somehting, but you shoulldnt have to dismantle teh throttle body to take the heads off... jsut pull the whole tb assembly off.. the guy that worked on it wasnt any help either (couldnt understand a word he said anyways) any help would be appreciated, it's driving me nuts.
 

·
Registered
Joined
·
2,656 Posts
Discussion Starter · #3 ·
i'll check when i get it home. if not, i guess i'll be paying a visit to the pick and pull. i need to look for some other junk anyways.
 

·
Registered
Joined
·
2,656 Posts
Discussion Starter · #4 ·
hmm.. all i see is the internal spring... maybe a picture of the way it should be would help? guess i'll be paying a visit to teh junkyard. the spring goes on which side? towards teh front or teh back of the car?
 

·
Registered
Joined
·
2,663 Posts
Well, when you visit the j-yard, just look and remember how and where it came off and you'll have your answer :)

Jay
 

·
Registered
Joined
·
2,656 Posts
Discussion Starter · #6 ·
i need to know what i'm looking for tho... hmm. maybe i'll take a picture of what i have, then compare to one at a junkyard.
 

·
Pedal Faster
Joined
·
2,658 Posts
If you get nothing in the bone yard, most auto parts stores have a cabinet full of throttle return springs.
 

·
Registered
Joined
·
2,656 Posts
Discussion Starter · #9 ·
yep... no spring there. guess i'll be picking one up. come to think of it, there never was one there. maybe it was because the throttle boby was gummed up it felt ok.
 

·
Registered
Joined
·
2,656 Posts
Discussion Starter · #10 ·
yep. no spring. i found both the mounting points, and went to teh store and got one. now, if anything, there is too much resistance. but now my acceleration and throttle application is a bet more precise... (and my lead foot has been remedied.)
 
1 - 10 of 10 Posts
Top