TCCoA Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2,894 Posts
Discussion Starter #1
Hey Guys,

I'm a bit worried. A couple of days ago, I turned a right corner on a residential street normally. After the corner and give it a bit of throttle, it seemed to slip slightly twice, then something knocked in the drive train.

Then again on a right turn heading to work, I decelerated, and as I was turning the corner, I hear a sound like metal cogs slipping over metal for about 2 seconds. It just stopped after that and the rest of the turns were fine.

I just bought the thing over a month ago and haven't had it on a hoist yet. I've had a rattle from the cat heat shield at low RPMs but thats it.

The calipers and rotors were all redone before I bought it and it looks like the bearing were done as well. The nuts on the spindles look new. I've had the wheels off to change over to my winters and things look good in there. It has 120,000 miles on it.

Is there something that I can check out? I know that I really need to get the thing on a hoist and have the drivetrain checked.

Thanks for your suggestions.

Brad
 

·
Registered
Joined
·
724 Posts
I got 3 guesses.

1. T-Lok headed south if you got one.

2. Ball joint.

3. Bushings on the rear diff wearing out.

At least that's what I would check first.
 

·
Registered
Joined
·
2,895 Posts
id shoot for ball joint.....my friends car does it and he has both side bad ball joints
 

·
Registered
Joined
·
724 Posts
Nope, I was refering to the ball joints up front. I have yet to rip a front end apart, but what's on the lower control arm?

Edit: It could also be something like bushings for the upper control arms. My car pops a little when I get it set in a corner, but that's cause on of the endlinks in back is busted.
 

·
Registered
Joined
·
2,894 Posts
Discussion Starter #6
I've tried moving the front wheels to see if there is play in the tie-rod ends and they seem solid. I think that the noise is coming from the driveline behind the tranny somewhere.

I really need to get it on a hoist. I am thinking CV joint somewhere back there.
 

·
Registered
Joined
·
2,894 Posts
Discussion Starter #8
I had it on the hoist today, and all bushings, joints and CV boots look great. The drivers' side engine mount is cracked but intact. The IRS mounts are good. The diff fluid looked fine, clean and no particles. It actually looked like things are in good shape.

Thanks for the suggestions. Maybe if I ignore it, it'll go away?
:rolleyes:
 

·
Registered
Joined
·
2,895 Posts
something has to be the matter....could it be a possibly tranny problem?
 
1 - 10 of 10 Posts
Top