TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5,408 Posts
Discussion Starter #1
I need to know if you can use a 96/97 tps and wiring on a 94/95 tb or even better yet if I can use a second gen mark tps on my first get mark throttle body. The reason I ask and need to know is I'm in the process of doing a motor swap in my 97, and the bird tps wiring would plug in perfect to a gen two mark viii tps sensor instead of having to splice in the old style of connector (93-95 mark/94-95 bird) into my 97 wiring harness. I've compared the two new sensors in person at pepboys and they look identical from what I can see other than the plugs.

Thanks for the help. I'm hoping this is one of those things that changed shape but retained function like iat, ect, iac, evr, etc....
 

·
Premium Member
Joined
·
5,862 Posts
Tps

I just went through all that, and 94-97 Thunderbirds / 96-98 Marks all use the exact same throttle position sensor. I don't know about the older Mark VIII's, but I would guess they are they same sensor, too.

(Also the same as 95-04 Crown Vics, 97-04 Trucks/Vans, 96-04 Mustangs, 96-99 Taurus, 95-02 Lincolns, etc, etc)

Unlike the IAC which Ford seems to have chosen a million different ones.....

EDIT: Here are some TPS part numbers my research has turned up:

Standard Motor Products TH157T, TH157
Original Engine Management 99035
Airtex / Wells 5S5115, ZZM318851, TPS245
Delphi SS10387, SS10386
Motorcraft DY967
BWD EC3025P
Master Pro Ignition 2-99035
BBK 1685
Echlin CRB 219094, CRB 219093, EC129
Ford F4SF-9B989-AA, F4SZ-9B989-A,
F4SZ-9B989-AA, F79Z-9B989-AA,
F80F-9B989-AA, F80Z-9B989-AA
 

·
Registered
Joined
·
5,408 Posts
Discussion Starter #3
Can anyone tell me if the pin out is the same between a gen 1 mark VIII tps and a gen 2 mark VIII or 96/97 tbird tps? Also if the operating voltage and voltage range are the same?

Thanks,
Chris_Murder
 

·
Premium Member
Joined
·
5,862 Posts
Can anyone tell me if the pin out is the same between a gen 1 mark VIII tps and a gen 2 mark VIII or 96/97 tbird tps? Also if the operating voltage and voltage range are the same?

Thanks,
Chris_Murder
Alright, Chris. It looks like the plug is physically different, check this out:

Mark 8 Gen1 TPS:


Mark 8 Gen2 TPS:


As far as "pin outs", they are the same and as far as I know, ALL TPS's sweep from 0-5v so you can test them that way. You're welcome and good luck!
 

·
Registered
Joined
·
5,408 Posts
Discussion Starter #5
Thanks rick I think I'm going to try it. 96/97 tbird sensor on the gen 1 tb looks to me from a mechanical aspect that they are the same. The less amount of residing or splicing the better.
 

·
Registered
Joined
·
1,273 Posts
I'm going to revive this so i can ask a dumb question, but I'm not finding much info on it. so here it is...

my TPS seems to be at 18% when the throttles closed, is that normal? had a code for voltage out of range, and i had to change it the other day, and i noticed both the old one, and the new one sit at 18%. at least the code is gone now with a dealership part instead of the Oriely's special...
 

·
Super Moderator
Joined
·
9,136 Posts
Perfectly normal, mine's the same way. Goes to about 95% at WOT.
 

·
Registered
Joined
·
1,273 Posts
ok, i thought so, thanks :)
 
1 - 9 of 9 Posts
Top