TCCoA Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
240 Posts
Discussion Starter #1
I had a post on the old forum about a problem that I was having and I was told that it was the Throtle Positioning Sensor. I was wondering how much one of these would be and where it is located in my car. I was looking in a tear down manual and didn't find anything that seemed to be that part. So I am turning to you. Any help would be greatly appreciated.

Christopher
 

·
Illinois Chapter Director
Joined
·
1,787 Posts
What is the problem you are having??? The TPS should read in the neighborhood of .98 volts. You can tap into the center(?) wire on the harness to read the voltage or use a scanner to watch the voltage.

I installed a 75mm TB and a friend drilled out the holes and adjusted the TPS til the voltage was correct. It took about 25 minutes or so or playing with it on the car during idle, but we eventually got it under 1 volt. Ordering a new one might not fix the problem. Just don't get aggressive with the adjustment or you can break the TPS.
 

·
Registered
Joined
·
240 Posts
Discussion Starter #3
What I have is a problem during acceleration. I have good acceleration up to about 3500 rpm and sometimes it will hang up and not go any higher. The only thing that I can do is to let up on the gas and let it drop back down and then try again.:confused:

Christopher
 

·
Registered
Joined
·
240 Posts
Discussion Starter #5
There is no jerking. It just comes up to power to 3500 and then it feels as though it loses all power but keeps the 3500. As of right now I just have a K & N cone filter installed instead of the air box. I have other mods in mind but I am not going to continue with then untill I have resolved this problem.

Christopher
 

·
Illinois Chapter Director
Joined
·
1,787 Posts
What year is the car and does this occur when you are going into OD? When was the last time you changed the trans fluid? Not like I'm certain or anything...but it could be time for the major trans flush.
 

·
Registered
Joined
·
240 Posts
Discussion Starter #9
I have a 97 V8. I did a flush just over a year ago but I have been looking into doing the J-Mod and at the same time going over to Mercron V. I have not had the chance to test the sensor. My dad is a mechanic but he has been out of town, he is supposed to be back this saturday so I am holding off until then.

Christopher
 
1 - 11 of 11 Posts
Top