TCCoA Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
709 Posts
Discussion Starter #1
my tranny seems to be running okay except it wont shift from 2 to 3 if throttle is more than say 70 percent. If I'm running 2nd gear up say to pass or something it will never shift.... Infact if I don't "let" it shift it will bouce off the red line till the cows come home! I just have to let off the peddle for a second but if its over 70ish percent open it will not bother.

Whats up with that???

Jake
 

·
Registered
Joined
·
1,411 Posts
I had something similay with my stock transmission... sometimes at full throttle, it would either not shift, shift late, or lose almost all power. I don't know what it was, but after putting in a '99 GT 4R70W, I have had zero trouble. The GT trans even shifts firmer than the stock. I know the 94-95's had problems with the accumulators (I think) resonating in the case, and wearing out. That may have been what was causing my problems (It would buzz like a barrel of angry hornets in P and N).

Your problem may be different, though...
 

·
Registered
Joined
·
709 Posts
Discussion Starter #3
so u have a '99 GT 4R70W in your tbird then? Mabie you can tell me how the installation of the GT tranny goes?? No one else could tell me! Other than the GT flexplate, TC and tranny was there anything else you needed? Are all the hook ups the same? Plug and play?

If my 4R70W ever kicks the bucket I would try to find a GT tranny myself.

Thanks,

Jake
 
1 - 3 of 3 Posts
Top