TCCoA Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
488 Posts
Discussion Starter #1
my trans is making a strange whining noise, (im pretty sure its comin from the front of the transmission)
its very quiet and i only hear it at idle and only sometimes. but it is drivin me nuts.
i bought this trans from dennis a few months ago. it is the bulletproof 4r70w. i have yet to take it to the track or even drive it hard, but i drive it to work ( 2 mile round trip) daily and to school (40 mile round trip) twice a week and i drive it around town. i believe ive put 4000 miles on this tranny now.
it has a 3000 stall morris converter and the o/d light flashed a few times but now it wont do it anymore. the fluid does not look new. it loox a lil darker than it should be and smells a lil burnt

any opinions on what xactly the problem is? i may not have given yall enough information, i kno. but this is all i know. i wasnt able to find a code in it but the light did flash a few times
i was thinking that maybe the tc is acting up somehow and slowly burning up the tranny........ sound right? i dunno

im taking manual transmissions next quarter then automatics after that so maybe then ill be the one answering the questions, but for now i have to ask

oh yah i guess i should mention that it drives perfectly normal. it shifts hard and it drives the same as it did when that trans was swapped in there
thanx very much
 

·
Registered
Joined
·
3,178 Posts
Might be the pump whining, but its hard to tell from your description. If that light flashes again get it to an autozone and read the code. And if the fluids turning color i'd swap it.
 

·
Registered
Joined
·
7,557 Posts
Seems to be some tranny problems going around...

Happy birthday! :woowoo: :znanner: :zbeer: :ztoohot:
 
1 - 3 of 3 Posts
Top