TCCoA Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
I have a 95 cougar that had a 99 grand marquis trans swapped in about 2 years ago. I have since fried that trans and have now swapped in a 96 t-bird trans.

I have swapped over the valve body that has been j-modded, 3500 stall torque converter and all the solenoids and parts to the upgraded connections.

The only gear that I have is 1st gear. The rpms drop in all gears but 2nd and the car only egages in first. I have been trying figure it out for the last couple of days with no success. I was hoping someone may be able to point in the right direction on what to check.

Thanks Rick.
 

·
Registered
Joined
·
4,407 Posts
MLPS switch. Make sure its properly lined up. Start there
 

·
Registered
Joined
·
97 Posts
Discussion Starter #4
I'm a bone head, I figured it out. I somehow managed to forget to seat the mlps back into the slot on the inside of the trans. It works now, pretty sad it took me a couple of days to figure it out.
 

·
Registered
Joined
·
1,222 Posts
Glad you got it figured out Rick. I'm going to be back in town Thursday afternoon probably. Kil-Kare?

-Rob
 

·
Registered
Joined
·
97 Posts
Discussion Starter #6
I am not sure yet, I still have to finish up the exhaust and a small coolant leak. I drove down to the end of the block and it seems to be okay but in park and neutral it is idling a little high 1200 rpms. Might be from all the changes and no cats yet. I am going to try to get it finished tomorrow.
 

·
Registered
Joined
·
1,222 Posts
I am not sure yet, I still have to finish up the exhaust and a small coolant leak. I drove down to the end of the block and it seems to be okay but in park and neutral it is idling a little high 1200 rpms. Might be from all the changes and no cats yet. I am going to try to get it finished tomorrow.
Did you ever get it retuned after the trans and converter?

-Rob
 

·
Registered
Joined
·
97 Posts
Discussion Starter #8
Did you ever get it retuned after the trans and converter?

-Rob
I had it tuned after we put in the converter and trans. I think it just needs to be tuned again after all of the changes this go around. I thought I would have fixed the oil leak with a new pan gasket but it turns out to be even worse...when rains it pours!
 
1 - 8 of 8 Posts
Top