TCCoA Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
43 Posts
Discussion Starter #1
i havw 165k on my transmission
i have it flushed ever 30k...never had filter changed
the tranny works fine..

how ever i have a small leak by the flywheel...i believe it the front seal...
im thinking about using the Slick 50® High Mileage Automatic Transmission Treatment after the next flush.....good idea???????

anybody have a good or bad experience?...
or should i just let it leak?...

trent
 

·
Registered
Joined
·
43 Posts
Discussion Starter #3
yea...didnt think so....but hate to spend a ton of money on a small leak....

is it worth it to remove the tranny and change the seal on a 165 mile xmission?

any advice?...

is it hard to do?....i would say im a experienced mechanic...but very inexperienced when dealing with transmissions...


trent
 

·
Premium Member
Joined
·
6,617 Posts
165k I'd say it's time for a transmission. The leak is probably a sign of a worn bushing or something like that.
Alan
 

·
Premium Member
Joined
·
1,362 Posts
My T'bird has about 200,000 miles on her now. It had 149,000m when I bought it. The front seal started to leak (or was leaking) not long after I got her. Additives will not stop the leak, or slow it for that matter. I've tried a few. I just keep an eye on it and add fluid as needed. I can't afford the labor to replace a $15.00 seal. I'm waiting till I have to replace or repair it. I just had her serviced and flushed, and a cooler installed. I was told it shifts fine and all looked well (for 200,000 miles).
 
1 - 6 of 6 Posts
Top