TCCoA Forums banner

1 - 7 of 7 Posts

·
Moderator
Joined
·
8,239 Posts
Discussion Starter #1
I have the transmission mod done, with all new springs and accumulators, and the drilled seperator plate. When I first got it, I noticed that on wide open 1-2 manual shifts I would squeek the tires. But under half throttle shifts, it seems to be squeeking the drivebelt. Is this right or am I crazy here?

Also, after a few hard shifts, the drivebelt smells like burned rubber. The drivebelt is a basically new goodyear gatorback, and it is installed correctly.

So, am i squeeking the belt, or am i nuts?

Justin
 

·
Ohio TCCoA
Joined
·
863 Posts
Ok, wo why causes it to do this and what are possible ways to fix it? I have the same done to my tranny and have the same prob. I alos did notice it with factory tranny.


later,
jay
 

·
Registered
Joined
·
1,846 Posts
Justin...

I have the same effect when I'm at part throttle on the 1-2 shift and also on the 2-3 shift with other people in the car. It's definitely the belt slipping. I thought I was the only one with this symptom when I mentioned it to A-Train back in october. It doesn't really bother me, so I don't call it a problem. It's just nice to know that it's not uncommon.


Jim
 

·
Ohio TCCoA
Joined
·
863 Posts
Well my belt is getting worn and I have a set of underdrives around so I will be doing that sometime soon maybe a new belt will help it,

later,
jay
 

·
Registered
Joined
·
1,846 Posts
Please let us know if a new belt cures the "symptom" I doubt it though..


Jim
 
1 - 7 of 7 Posts
Top