TCCoA Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
hey guys, Im having some trouble with my transmission. I have a 95 lincoln towncar with 4r70w transmission, i know this is not a lincoln forum but no one there could help me and the referred me here because they said you have a lot of knowledge. Basically i had my transmission rebuilt recently, reinstalled and have everything hooked up it appears and 12 qts of fluid in there. Now the problem is if i want to start it, sometimes it starts in park other times i have to shuffle through the gears and may not start unless its in drive. Also if i have it in reverse the lights come on for reverse, but if i go to nuetral the lights stay on. And the big problem is i have no movement. No matter what gear i am in, the car doesn't move, the engine revs but no movement. Im not sure where to start and what im looking for. the linkage looks ok but the bolt and nut are lil loose where it connects within. Any help will be greatly appreciated. Thanks guys.
 

·
Registered
Joined
·
2,977 Posts
Go to Autozone or your local parts house and ask for a neutral safety switch for your car. That should get it.

Also, you need to have it properly adjusted to have it work correctly and there are marks on it to help you there. You put the transmission in neutral and align the neutral marks on the switch and then tighten it down. When you are done, check it to make sure it didn't move and it should be good to go.

Darrin
 

·
Super Moderator
Joined
·
12,230 Posts
I may be wrong but don't these transmissions hold about 15 Quarts? I would think that 12 quarts in a rebuilt trans might not be enough. You may be about 3 quarts low. Don't quote me on this one, but you may want to look into it.

Check your level and be careful not to overfill. You may need more fluid, especially if you've added an auxilary trans cooler.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #8
Thanks for the info.. i didn't know that the nuetral safety switch had different name. THis is my first automatic so new to the stuff. But thanks again, i try and adjust it, the switch is new just must be misalligned.
 

·
Newbie
Joined
·
5,650 Posts
If it is misaligned and it still is not working, it's possible the transmission shop didn't position the manual valve correctly. That would be scary since it was done by a shop, but it would cause the car not to move in any gear. Find out if the switch is aligned and working first.
 
1 - 9 of 9 Posts
Top