TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
174 Posts
Discussion Starter #1
I had the trans rebuilt a couple of years ago. Shifts are very quick and firm but not banging into gear. Lately when I do a near or wide open run I'm hearing a squealing on the 2/3 shift. Not tires I'm pretty sure. Do clutches or bands slip and would you here that??? Thanks
 

·
Super Moderator
Joined
·
7,527 Posts
It’s most likely the serpentine belt.
 

·
Super Moderator
Joined
·
12,083 Posts
Did you Jmod the valve body & accumulator springs at the time of the rebuild, before the rebuild or since the rebuild? My guess, based on your description, is that you did not.

I'd get that done if you really want banging into gear shifts. Any questions about it just let us know.
 

·
Super Moderator
Joined
·
10,663 Posts
Lazarus' tranny squeaks a bit going into 2nd and 3rd; as the TC is locked as soon as it exits 1st.
Don't ever do a wot into 4th; that's a sure way to kill a tranny.

It sounds like a dry bolt getting ready to snap; only louder.

It's a hardware fail in my case, IMHO; that tranny's always done it. It's not the VB, I changed it. It's a shaft seal fail somewhere, or a leak in the case.

I think one good wot 2-3 shift will leave pieces laying in the road.

I hope it's your Serp Belt, OP.

I'm waiting to replace this one with one I have in the garage, when it finally dies.
If I can, I want to see why it does that, but I doubt it will be intact enough to autopsy.

:)
 
1 - 5 of 5 Posts
Top