TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
60 Posts
Discussion Starter #1
Hey guys,

I'm having some issues with my 1995 4.6 tbird and I was hoping someone here might be able to provide some helpful information. The issues is that i have been getting a vibration for a few months now around 2000-2500 rpm. I suspect that this is coming from the torque converter/flexplate because it does it in neutral as well. The vibration of course started out very faint and is very noticeable now. Now I also have an issue with it trying to stall out when put in drive from park and when im slowing to a stop or moving at about 5- 10 mph the car surges as if im applying the brake off and on. Once stopped it idles but a little higher then usual. Also the torque converter will lock up and then immediately unlock under light throttle around 40 mph, i have to push it passed 45-50 mph to get it to lock up and not unlock or just let off the gas and it will lock up.

Prior to these issues I had and issue with the car randomly going to neutral when hot so i changed out the shift solenoids and the tcc solenoid. this fixed the going into neutral issue but i this is when the weird locking up issues started. I'm thinking I might have gotten the wrong tcc solenoid. Any chance that a different year solenoid could cause this? The one that came out had a black casing and the one i put in had a metal casing.

The trans is out of a 97 crown vic according to the serial. I rebuilt it and did a jmod on it as well as changed out the accumulators and springs. I also put a 2800 stall (really like a 2400) converter in it from FTI and a Performance automatic flex plate in (PMA-PAX28110). The flexplate didnt fit perfect the studs of the torque converter were touching the inside edge of the holes once installed.

The car is cammed with comp 270 ah and tuned remotely by Lasota.

I suspecting that i should probably get a new torque converter/flexplate and change the tcc solenoid. What do you guys think? Please advise.
 

·
Super Moderator
1997 Thunderbird 4.6, 1998 Mark VIII LSC
Joined
·
9,452 Posts
Mmmm, your comment about the flex plate not lining up perfectly with the converter makes me wonder if it's not centered perfectly and is inherently out of balance as a result. A Mark VIII, SN95 Mustang GT or Marauder converter/flex plate combo will give you the same stall and be factory quality parts. They're fairly cheap too.
 

·
Registered
Joined
·
498 Posts
If you are talking about the FTI SB2800 I have the same one. If you are still on warranty try to return it because mine didnt have that fitment issue, it matched the flexplate perfectly. So your issue may very well be that the studs arent spaced correctly on the TC. What else is done to your engine? I just swapped in a PI engine with 262s, UD pulleys and long tubes with an SCT chip and mine stalls at 2900. Did you check the part number before putting it in? They have a 2400 stall (SB2400) and they look exactly the same and may have been boxed wrong. They have the number stamped into the converter itself. If its correct you might have gotten a bum TC to begin with. I had to pull my car back apart because the rear main leaks but it should be back together before next weekend (knock on wood).
 

·
Registered
Joined
·
60 Posts
Discussion Starter #4
Mmmm, your comment about the flex plate not lining up perfectly with the converter makes me wonder if it's not centered perfectly and is inherently out of balance as a result. A Mark VIII, SN95 Mustang GT or Marauder converter/flex plate combo will give you the same stall and be factory quality parts. They're fairly cheap too.
Thanks for the response. I do believe this is part of the issue and plan to change it out when i get a chance.
 

·
Registered
Joined
·
60 Posts
If you are talking about the FTI SB2800 I have the same one. If you are still on warranty try to return it because mine didnt have that fitment issue, it matched the flexplate perfectly. So your issue may very well be that the studs arent spaced correctly on the TC. What else is done to your engine? I just swapped in a PI engine with 262s, UD pulleys and long tubes with an SCT chip and mine stalls at 2900. Did you check the part number before putting it in? They have a 2400 stall (SB2400) and they look exactly the same and may have been boxed wrong. They have the number stamped into the converter itself. If its correct you might have gotten a bum TC to begin with. I had to pull my car back apart because the rear main leaks but it should be back together before next weekend (knock on wood).
Doubt its still under warranty but i will check, and I do remember seeing that it was the correct part number before i installed it. Thing isn't even locking up any more at any speed. I plan to replace it with a 10" built by a local shop here in Atlanta.

And as far as mods it has the 270 cams, slightly ported NPI heads, Pi Intake, cold air intake, shorty headers, dual exhaust, 3.73 LSD and a tune.
 
1 - 5 of 5 Posts
Top