TCCoA Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I am looking for help on my AOD, I have a 90 Lincoln Mark VII, with an AOD that has all Art Carr components, and also a manual valvebody, TCI 3600 Stall lock up torque converter. It shifts fine in 1st & 2nd, but in 3rd and 4th is seems like it doesn't exist. could it be that the torque converter is not engaging for 3rd and 4th??? It runs great cold but after 5 -10 mins, it acts like it is slipping all the time. It also is a fresh rebuild
 

·
Registered
Joined
·
3,178 Posts
No 3rd and 4th gear (ie. neutralling) would lead me to suspect things like:

Possible VB problems
Direct clutch seals not working
Direct clutch frictions worn
Splines of the Direct Clutch drum/Input shaft/Torque converter

The input shaft is splined directly between the drum and TC, so in 3rd and 4th gear it's always locked up. High HP cars have been known to twist or break input shafts, while lower HP cars will see more seals/frictions wearing out. The aftermarket VB is a giant ? to me, a sticking valve in there could possibly cause the problem. Get it looked at soon though, hopefully its something simple.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
I don't know what I am pushing for HP or TQ, but i have a 306, with a 9.9:1 compression, Edelbrock RPM heads, and RPM intake,#24lb injectors, 75m MAF and 255lph fuel pump and a A-trim vortech supercharger and a free flowing exhaust. with 3.73's on the rear
 
1 - 3 of 3 Posts
Top