TCCoA Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey all,

I'm having a transmission problem which I need some advice on. It's a '95 V8 with 117k miles on it. The other morning when heading to work, my car started shuddering pretty badly. I assumed that it was time to get the trans fluid flushed (since it seems a pretty common problem with our cars). The shuddering only occurred when shifting into 3rd. Unfortunately briefly after the shuddering started, I lost 3rd completely. Once it shifts out of 2nd, I can rev it all the way to redline and get nothing.

I got the fluid flushed and filled with Mercon V, as recommended by everyone on the board. The 1-2 shift is smooth (I was having hesitation issues with it before) but I still have nothing past 2nd. Am I looking at major work like a rebuild or is there something else I can look to do?

With the high amount of miles on the car and various other nagging issues, I'd rather put $1500+ into another vehicle (any V8 'Birds left with low miles?) ;-) Any advice would be greatly appreciated!

Thanks,
Som
 

·
W&S Motorsports
Joined
·
161 Posts
Tranny Operation

To shift into 3rd the EEC-V activates shift solenoid SS2 to apply the direct clutch so you may want to check the wiring from the EEC-V, the connector in the transmission.
The tranny pan will have to be dropped to clean the SS2 solenoid. Valve body may need to be taken apart and cleaned with non chlorinated brake cleaner. The shift solenoids are hard to clean. While you have the pan down check the main pressure regulator valve, replacements are not avilable fom Ford but Sonnax makes a replacement available from your tranny hard parts dealer.
The MLPS could be defective also. On the 97 cars an AutoTap can give you a voltage reading which you can check against a table of values, I do not know if the earlier OBDII port gives this voltage. An Info Panel will give you an A/D count of around 433 when in O/D.
 

·
Registered
Joined
·
855 Posts
not to discourage you or anything but here's what happend w/ my tranny:

had a similar prob..........car wouldn't shift into third until i either a. eased up on the throttle b. waited a few second or c. had the car cool down.

every once in a while when the tranny got really hot the car would miss 3rd. it would rev up to the limiter and not go in,........until i hit a speed fast enough to go right to fourth.....if i dropped out of o/d manually it would buck the car and then eventually go in 2nd or 4th.

tranny did this for a while,.....then i decided to do the j-mod and found out it was already done on my tranny somehow,.......and when i filled it back up w/ tranny fluid that's when all hell broke loose,..........ended up needing a rebuild. burnt direct clutch bands (direct clutch turns on in the 2-3 shift)
 

·
Premium Member
Joined
·
8,239 Posts
Would someone please verify that this is the correct part number for a set of 1995 4r70w shift solinoids?

F7AZ-7G484-AA SOL ASSEMBLY-TRANS SHIFT $32.60

Thanks,
Justin
 
1 - 4 of 4 Posts
Top