TCCoA Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2,638 Posts
Discussion Starter #1
 

·
Registered
Joined
·
2,638 Posts
Discussion Starter #4
weswing04 said:
cool, numbers seem a bit low?
Yeah, they were lower than I was expecting. I mean, I know about power loss through the driveline, but I wasn't expecting that much loss. Then again, it is a stock PI motor with single exhaust and 3.08's. The torque should jump up pretty good once I get the 3.73's in and true duals.
What kind of numbers do stock '94/'95 4.6's get at the rear wheels?
 

·
Registered
Joined
·
2,514 Posts
even with out the drive train mods i would those numbers still seem a little to low. I know you can get around 206 at the rear wheels with just a PI intake install and cams and dual exhaust. What kind of chip do you have in it???
 

·
Moderator, Red Sox Nation Rabid Fan, TCCoAAC Found
Joined
·
3,165 Posts
1/4 mile time?
 

·
Administrator
Joined
·
14,211 Posts
tinman_72 said:
What kind of numbers do stock '94/'95 4.6's get at the rear wheels?
I got 175/227 with a j-mod, red diablo chip, K&N filter and a civic tube. Keep in mind, gears do not add torque, they just get your torque to the ground faster.
 

·
Registered
Joined
·
2,556 Posts
tinman_72 said:
Yeah, they were lower than I was expecting. I mean, I know about power loss through the driveline, but I wasn't expecting that much loss. Then again, it is a stock PI motor with single exhaust and 3.08's. The torque should jump up pretty good once I get the 3.73's in and true duals.
What kind of numbers do stock '94/'95 4.6's get at the rear wheels?
i saw a 95 cougar with a k&n filtercharger put down 165hp i think..forgot the tq.

i put down 211/265 with pi intake/cams/maf/SCT tune...stock npi heads..
 

·
Registered
Joined
·
2,638 Posts
Discussion Starter #9
MattsLE97 said:
even with out the drive train mods i would those numbers still seem a little to low. I know you can get around 206 at the rear wheels with just a PI intake install and cams and dual exhaust. What kind of chip do you have in it???
I have a PI intake and cams and NO dual exhaust and I have 207HP. Seems fairly consistent. I don't have a chip... it was dynotuned and flashed by Jerry (SCT).
jordansypek said:
1/4 mile time?
Never been to the track...
weswing04 said:
i saw a 95 cougar with a k&n filtercharger put down 165hp i think..forgot the tq
Assuming this is normal, I have gained ~45 rwhp. Not bad in my eyes. Don't get me wrong... I know that this is not exactly the fastest car in the world, but when you are used to 2.3L Ranger power it sure seems like it!
 

·
Registered
Joined
·
2,556 Posts
Yeah, im sure its nice...we were just saying 207hp for a PI motor is a lil low. but it could be the 95 drivetrain and dyno differences..
 

·
Registered
Joined
·
2,638 Posts
Discussion Starter #11
Maybe I should put it in a less argumentive form... Considering the mods that I have, what should my numbers be? The motor is fresh... came from Greenleaf with less than 15,000 miles on it so I am sure there should be no problem there. It runs beautifully. I've never had an engine that runs so smooth and always starts on the first try, never dies at stoplights, etc... The only thing that is not new or like-new is from the transmission back. (Even though it shifts like a champ.) Yes, it is the original '95 transmission, but for now it works well.
Don't tell me that I need more mods to give it more power. Your comments imply that I should be getting more power with what I already have. Where should I start looking when everything (seems to) work perfectly?
 

·
Administrator
Joined
·
14,211 Posts
Talk to Palmguy. It took him forever to get all the power out of the explorer motor that he was expecting.
 
1 - 12 of 12 Posts
Top