TCCoA Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
342 Posts
Discussion Starter · #1 ·
I got an xcal from lonnie and when I have it tuned for premium gas I hear like a detonation knock but when I tune it to regular it goes away, and when I retur it tostock It runs like crap. I men it dles rough and misses. What could the problem be?
 

·
Registered
Joined
·
1,212 Posts
Well the first thing you need to do is check out your vehicle. Then you should contact the tuner (me). I don't know who you are since I don't go by the TCCoA names and no one uses their real name here. I've done seven T45 swaps and the only one I remember in a 95 is with a Mark engine swap.

There could be any number of reasons why it is detonating. If was doing this when you first installed the program you should have contacted me since you have 30 days for me to correct the program.

Your state used additive in the winter that lowers the octane level also. Then being a 95 model I've found the biggest problem is that the intake and combustion chambers are full of carbon. This raises the compression and heat developed in the engine. The other problem is a dirty MAF.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #4 · (Edited)
It wasn't doing it when I first installed the tune. Could It also be because I put a 96 style intake? I am just tryin to get it fixed. Not fussing or complaining, just tryin to figure it out. I also appreciate all the input from everyone.
 

·
Registered
Joined
·
1,212 Posts
Unless the rings are installed wrong you shouldn't have oil blowing by to the point of causing a build up and detonation. Your program has enough of a safety margin that you shouldn't have any detonation as long as the engine was assembled correctly. Also you have the ability to pull timing out of the program with the ODA. You should have done this already and not continue driving it with the detonation problem.
 

·
Registered
Joined
·
342 Posts
Discussion Starter · #7 ·
I have not been driving it. I am trying to find out exactly hat is wrong with it so that I can possabbly get my 1000$ back from the reman company and get my motor rebuilt again since it only has 500 miles on it and I have an air filter that get's soaked with oil in the first 10 min of starting it up.
 
1 - 7 of 7 Posts
Top