TCCoA Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
118 Posts
Discussion Starter · #1 ·
every time i go over bumps i feel my transmission clunking around and hitting the housing (?) an exhaust shop told me the u joint is probably trashed because they could move the driveshaft up and down a bit, however the yolk and drive shaft are tightly held together and not showing wear.......

heres the interesting part...... about 5 months ago i had a waterpump and motor mounts put in and when i got the car back i had 2 problems, 1. the aforementioned clunking going over bumps that i felt in the shifter. and 2... popping in the steering when turning... the steering problem turned out to be nothing more than a VERY loose subframe, like each bolt was 3/4-1 full turn loose.... now we have checked the lower bolt in the trans mount and it was tight, but i dont think the top bolts are tight, we couldnt get at them to tighten them..... i just ordered a solid trans mount cause the sc has 105k and im sure the trans mount is getting due anyway...... do you think im in the right area on the noise? a u joint would make vibrations at speed right? we've had the sc to over 120 with no problems, other than the noises coming from the trans when it goes over bumps....

im stumped, any help appreciated.
 

·
Refrigerator Raider Hater
Joined
·
11,719 Posts
You said you ordered a trans mount....put it in and see if it's gone.

It could also be play in the rear gears.
 

·
Registered
Joined
·
118 Posts
Discussion Starter · #3 ·
i dont think its play in the rear gears, if anything im feeling it in front of the shifter, however one of my passangers once said he felt it on the right rear floorboard in the backseat.

oh and another reason im convinced its not the u joint, is this has been going on for about 7-8k miles now, and 6 months, and i have gone down the dragstrip a few times too (like 7-8 times probably total) and whatever it has has never broken.
 
1 - 3 of 3 Posts
Top