TCCoA Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
377 Posts
Discussion Starter #1
on the plenum leading into the intake manifold there is a 2 way brass fitting it has only one line leading to it. i cant find the other line and the diagram i got from the dealer shows it but not anything leading to it. I am only running about 7-8 pounds of boost because of it. any ideas
 

·
Registered
Joined
·
51 Posts
One of the lines at that fitting goes to the vacuum distribution "tree" on the wheel well in the corner by the brake master cylendar, I think if that line was missing the car would really run like sh!t.
The second line goes to the back of the inlet plenum for the SC in called a crosstalk tube and is about 6-8 inches long. This is likely the one that is disconnected since some people have tried to eliminate the tube altogether with no performance increases.
 

·
Registered
Joined
·
377 Posts
Discussion Starter #3
hey thanks for the advice traced it down and it was unhooked. car runs a ton better and actually have a decent brake pedal :D
 

·
Registered
Joined
·
377 Posts
Discussion Starter #4
also was missing tube from intake tube to pcv valve the boost is back to where it should be now 10psi
 

·
Registered
Joined
·
34 Posts
If you put a hose clamp on every vacumm line you can get to.And a plastic
tie on the smaller vac lines with nipples you will notice another gain in performance.
Try to put a clamp or tie on all the vac lines on the boost side of the vac line.
pcv valve lines ,ect.

randy
 
1 - 5 of 5 Posts
Top