TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
alright well my od light started flashing i took it to a local trans shop they ran a scan on it while driving it an said my speed sensor is cutting out at freeway speeds. which it comes on around 68mph when its held there for a little bit. they wanted a rediculous amount to replace it so i bought the part for 25 bucks at autozone an plan to install it. any tips i should know before hand? also where on the trans is it located i have a 96 4.6. just want to get it done an hopefully this fixes all trans problems except the leak. i just rebuilt it an cant really afford much more on this car right now. thanks

nick
 

·
Super Moderator
1997 Thunderbird 4.6, 1998 Mark VIII LSC
Joined
·
9,525 Posts
Pretty self explanatory. One 11mm (IIRC) bolt, slide the old out and put the gear on your new sensor. There's a small circlip holding the gear on. Just make sure you lubricate the o-rings with fresh ATF before putting it back into the tailshaft.
 

·
Premium Member
Joined
·
649 Posts
Just get it up on Ramps & be CAREFUL - VSS on Driver side aft Tranny - & YES you must fix leak or your screwed.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #4
sounds pretty easy just gotta wait for this rain to stop to fix it. as for the leak i dont have the money or time to take the trans out again im thinking just throw some lucas in there as i just rebuilt the trans an if it goes out again ill just swap a manual in. its not a horriable leak maybe a quart every 3 weeks if that
 
1 - 4 of 4 Posts
Top