TCCoA Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
2,656 Posts
is it when you let off the gas? my gf's mustang was doig teh same thing last night when she let off and it tried downshifting.... i'm clueless.
 

·
Registered
Joined
·
457 Posts
Yes, It could be the early stages of a bad torque converter. When I bought my 95 bird I had the same problem and they replaced the TC. I stopped the problem.

What happens is: while in top gear it wants to shift into overdrive, and when it does that it pulses into OD. when the torque converter is going bad, you can feel the vibration in the car. I suggest you get it checked quickly as it can damage the tranny if you let it go for too long.
 

·
Registered
Joined
·
373 Posts
now it stays stuck on 1 on the rpm's and when im at a light if i release my foot off the brake the car takes off. also when i came out from my parking lot at school i didnt have to press the gas the car just stayed stuck on 1 and drove on its own. i feel like the real owner of kid from (michael) night rider :confused:
 

·
Registered
Joined
·
457 Posts
now it stays stuck on 1 on the rpm's and when im at a light if i release my foot off the brake the car takes off. also when i came out from my parking lot at school i didnt have to press the gas the car just stayed stuck on 1 and drove on its own. i feel like the real owner of kid from (michael) night rider :confused:


Actually it's "KIT" from "Night Rider" . . . . . sounds more like tranny is shot. . .does it shift out of first gear . . .?
 

·
Registered
Joined
·
373 Posts
i have to put it in neutral so rpms can drop back down other wise it just stays on 1 or acclerates more. some mornings on cold starts it turns off and after that alot of vibration(i think the right term for that is shudder) going on. i also took it to the ford stealership to have it diagnosed and service guy told me nothing showed up but was kind enough not to charge me. i was told it could prob. be the computer. also had motorcraft tranny fluid, new filter,and felpro gasket serviced 2 weeks ago. cleaned the maf with electronic cleaner cleaned out intake. few months ago replaced the tps,iac,fuel pump,fuel pressure regulator,and fuel filter. over a year ago,egr,evr,heater core,oil pressure switch,pvc,coil packs,idler tensioner,pulley,spark plugs & wires (oem) just realized theyre a short my battery gauge is out so went straight to replace the only blown out fuse 5A and ending up causing a short and burnt out sensor in the tunk area, now a whole list of things dont function on my car due to 5A not working only thing i can think of was the mod of my headlights went from 9007 to 9006 maybe he didnt wire them right
 

·
Registered
Joined
·
2,666 Posts
Actually it's "KIT" from "Night Rider" . . . . . sounds more like tranny is shot. . .does it shift out of first gear . . .?
Actually, its "KITT" (an acronym for Knight Industries Two Thousand) -- the name of a fictional computer that controls the high-tech Knight 2000, a black Pontiac Trans Am T-top automobile in the science fiction television series Knight Rider.

And as far as the idle not coming down, you might have a sticky IAC valve. And of course, have you cleaned the MAF?

For the shudder, if it is the TC, then try changing the trans. filter and fluid. Try to get as much of the old fluid out of the system as possible. Refill with Mercon V, not Mercon III. See if that doesn't help. The updated fluid may help stave off the TC shudder.

Jay
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top