TCCoA Forums banner

1 - 9 of 9 Posts

·
Banned
Joined
·
3 Posts
Discussion Starter #1
Im not sure whats up with this tranny now. The problem happens around 60 mph when cruising or light acceleration and the car downshifts out of OD into 3rd, maybe 2nd. The first time was in traffic around 65mph. It did it, barked the rear tires, I almost got whiplash and wrecked the car. Its the same case every time, just not sure what is causing it. I just need to get it fixed before something breaks or wreck the car. My car is a 94 SC with a 98 mustang J-modded tranny and 04 merc merauder converter.
I would appreciate any help. Valvebody or Torque Converter?

Zack
 

·
Baby Huey
Joined
·
3,210 Posts
Thats a bad thing?

























Just kidding!
 

·
Administrator
Joined
·
8,167 Posts
No expert, but a bad MLPS is the first thing that comes to mind.

Joe
 

·
Super Moderator
Joined
·
10,895 Posts
Lol! I've done it more than a few times.

Posting while searching, lol. :)
 

·
Registered
Joined
·
6,111 Posts
hahaha sorry about that, I didn't look at the date, I was at lunch posting from my phone...I saw the OP's new post today, and didn't recognize the name, but saw that they are a local to this area, searched posts, read, replied, and here we are.

with that said, I still don't see a problem with a hard tire shredding shift :zdunno:
 

·
Super Moderator
Joined
·
10,895 Posts
I saw the OP's new post today, and didn't recognize the name, but saw that they are a local to this area, searched posts, read, replied, and here we are.
Wow, I must have missed something good; he's banned, and the posts are deleted. :rofl:

Impressive, for what seemed to be two posts. :)

So, politics, religion, or sheer idiocy? No details, I don't want to lock a thread. :)
 
1 - 9 of 9 Posts
Top