TCCoA Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hello Fellas,

On my 90 SC I noticed today while I was letting it run, I saw drops of coolant coming from the upper radiator hose, and drops of coolant from the hose that goes from the radiator to the coolant reservoir. I know that a few weeks ago, I might of added to much coolant into the reservoir.. not thinking to check the radiator first before I had did that. Also I noticed when I opened up the radiator cap that coolant begin to come out. (The car was cold when I did that yesterday). Any help would be appreciated. I know that upper radiator hose is a new hose.
Thanks
 

·
Administrator
Joined
·
8,034 Posts
Hose clamps tight? The system is pressurized, so you'll get some coolant when you first open the cap.

Joe
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
Thank you for the response I will check the clamps again. Is there a such thing over pressurizing the system? By me adding to much coolant to the system?

Thanks again
 

·
Newbie
Joined
·
5,650 Posts
It can't really be over-pressurized unless the cap is bad. The cap regulates the pressure of the system, sealing it closed when it is below the specified pressure and opening to release to the overflow tank when too high. As the system heats, the fluid expands and flows out into the tank, then cooling will pull it back in. But adding too much coolant would just result in the coolant spewing out of the top of the overflow tank. These cars don't have a dedicated overflow hose like some others.
 
1 - 4 of 4 Posts
Top