TCCoA Forums banner

1 - 13 of 13 Posts

·
one in a million
Joined
·
154 Posts
Discussion Starter #1
Hi,

I have been chasing a weird cutting out issue on my 95 cougar 4.6
sometimes it will do it under light acceleration but more likely under wot when fully warmed up.
cruising at 25-30 mph if i decide to wot it will shift down to 1st and right before 2 it cuts out and free revs.
it will go into 2 after i let off the gas with no problem.

all connections are good. new walbro 255 fuel pump, fuel filter, motorcraft plugs and wires, alternator.
no vacuum leaks or check engine light.

transmission shifts fine under normal driving conditions.

anyone have experienced anything like this ?
I'm lost and getting tired of thinking it could be this or that and throwing money at parts.
 

·
Super Moderator
1997 Thunderbird 4.6, 1998 Mark VIII LSC
Joined
·
9,652 Posts
Could be a failing one-way clutch. Stock 95 trans - any mods to it (e.g. Jmod)?
 

·
one in a million
Joined
·
154 Posts
Discussion Starter #3
I done the J-mod about 10 years back, mild with spring left in on 1-2 piston.
fresh fluid and filter last year and had to change reverse servo.

would adding a transmission cooler help at this point to get a few more miles out of it ?
 

·
Super Moderator
Joined
·
12,907 Posts
Adding a cooler always helps. (Unless you live in the great white north)
 

·
Super Moderator
Joined
·
11,018 Posts
Drop the pan and look for problems; a wasted roller clutch will leave metal stuck to the magnet; a stuck 1-2 accumulator can also cause that problem, especially if the spring broke and is wedged in place.

I'd look at those things first; post up a pic of the pan magnet.
 

·
one in a million
Joined
·
154 Posts
Discussion Starter #6
Hey all, Thanks for the replies.

Got around to dropping the transmission pan today, nothing out of the ordinary on magnet just black fine metal.
checked 1-2 accumulator piston which looks okay. no upper spring just purple bottom spring.
the filter fell easily off while removing pan, kinda wonder if maybe it was not seated all the way.
sealed back up with new filter and fresh fluid.. so far shifting nicely.

Trans cooler is next project.
 

·
one in a million
Joined
·
154 Posts
Discussion Starter #7
Hey all, just a little update..

Got a new radiator and transmission cooler in finally.
went with a Hayden 516 that included hose and fittings off amazon.
so far so good.. Adding seafoam trans tune before changing fluid from pan and converter seemed to help some.
 

·
Registered
95 t bird lx 95 dohc mark viii engine 98 rebuild trans jmod med stall
Joined
·
5 Posts
Glad you solve the issue, did you go with an oem radiator ?
 

·
one in a million
Joined
·
154 Posts
Discussion Starter #9
I went with a Spectra CU1551 radiator off Amazon.

as far as solving the issue, it has not cut out and is shifting better for now.

long as i don't smash it should last long enough until I can find another transmission.
 

·
one in a million
Joined
·
154 Posts
Discussion Starter #10
hey all.

Think I may have found the problem to be a faulty throttle position sensor.
I overlooked that, having replaced it 2 1/2 years back with a p e p boys cheap unit.
it was somehow heat and vibration related with a dead spot at random times.
not enough to throw any codes.

I replaced it with a azone duralast unit and so far it's running and shifting better.
 

·
one in a million
Joined
·
154 Posts
Discussion Starter #11
update; this hopefully was the problem.

After getting a code for the neutral safety switch.
It was dropping into neutral a couple times form second and overdrive.
I got under and took a look, both bolts were loose.
somehow I did not tighten them enough the last time I changed it.
went ahead and changed it out for a new one, so far so good..

I also have the starter wire by-passed straight to the ignition switch because the last one was not starting at times.
so I wouldn't know right away if the switch was failing.
 

·
Registered
Joined
·
1,993 Posts
cruising at 25-30 mph if i decide to wot it will shift down to 1st and right before 2 it cuts out and free revs.
it will go into 2 after i let off the gas with no problem.
Be careful with those WOT downshifts - on another model car, I rolled a sprag when that happened by accident.

If I want WOT at 25-30 MPH, I just put it in manual 2nd and let 'er rip. Keeps it from downshifting to 1st. The couple times I didn't do manual 2nd and it downshifted into first, it hit what felt like a rev limit even though I wasn't even at 5k. I was letting off at the time. A surprise downshift is rude as hell, hate that ****.

Al
 

·
one in a million
Joined
·
154 Posts
Discussion Starter #13
^Thanks for the heads up on the sprag..

I'm surprised the transmission has last this long for it's age and how I driven it.
 
1 - 13 of 13 Posts
Top