TCCoA Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
510 Posts
Discussion Starter #1
I have been having troubles with my right turn signal flashing quickly and having to nurse it to work; now when I turn either the right or left blinker, the engine rpm seems to rise a little WTF? Also, now when the cruise is on if I use the blinkers it turns the cruise off! It's like the turn signals are tied into the PCM! This old car is really starting to add up issues!
 

·
Baddest N/A NPI in Canada
Joined
·
2,118 Posts
I have been having troubles with my right turn signal flashing quickly and having to nurse it to work; now when I turn either the right or left blinker, the engine rpm seems to rise a little WTF? Also, now when the cruise is on if I use the blinkers it turns the cruise off! It's like the turn signals are tied into the PCM! This old car is really starting to add up issues!
I was there recently...

http://forums.tccoa.com/showthread.php?t=122467

My advice. Check the contacts in the steering wheel...
 

·
Registered
Joined
·
3,902 Posts
I know my car will turn off the CC when I turn on the hazard lights, at least at like 70+. Since the hazard lights use the same filament of the bulb as the brake lights, is power being directed to the CC module through the brake light wire when the hazards come on? Blinkers also work on the same circuit, but it doesnt make sense to me that it only does it to the left. If it's only to the left, I would be checking into a wiring problem. I wonder if I installed a diode on the wires going to the rear blinker/brake light ckt if it would stop power coming up to the CC module? Now you have me wondering. I'm going to check out a diagram at work tomorrow if I can get some time!
-Rob
 

·
Registered
Joined
·
3,902 Posts
Well I am looking at a diagram and it looks like where ckt 511 goes into the Multifunction switch would be the best place to put a diode to keep feedback from the turn signals and hazard lights from turning off the cruise. Ckt 511 is the light green wire on the back of the MFS. This is after the junction block so cruise should still deactivate with brakes. I should try this out sometime. Is there any ideas on what kind of diode I would need? Would a regular PCM diode from a power distribution box work fine?
-Rob
 

·
Registered
Joined
·
1,044 Posts
I think your problem is in the Multifunction Switch.

There are several threads on cleaning it, but you have to have a clean work area, and I understand there are parts that can fall out so search and read carefully, maybe even print off and have some handy.

Search terms _ multifunction switch _ or _ cleaning multifunction switch .
 
1 - 8 of 8 Posts
Top